Skip navigation
Currently Being Moderated

How to update the Mgls.dll file using the Mentor License Utility

VERSION 1 
Created on: Feb 15, 2012 4:17 PM by andrew_audova - Last Modified:  Feb 20, 2012 2:34 PM by guy_wettstein

There are times when updating to a newer mgls.dll is required to fix a licensing-related defect. The Mentor License Utility includes functionality to automate the updating of all older version copies of the mgls.dll files in a target installation area.

Demonstration:

(Embedded movie requires Flash. Click here to view MPEG-4 version)


 

 

Instructions:

 

  1. Download the "Full" version of the Mentor License Utility from SupportNet
  2. Run the Mentor_License_Utility_INSTALL.exe which extracts all the program files, creates a shortcut*, and launches the Mentor License Utility program. (See README.txt for version information)
  3. Navigate to and select the Tools > Update File > Mgls.dll > Current FlexNet version menu item.
  4. The File Replace Options dialog will appear. Make sure all checkboxes are selected and click the Next button
  5. Browse to the directory where the Mentor Graphics software is installed to (for example: C:\MentorGraphics\9.3.1PADS) and click OK
  6. Wait for all the mgls.dll files to be updated. This can take a few minutes or more.
  7. Once complete a notification of all files updated will be given. Click Close to exit the dialog, and File > Exit to exit the Mentor License Utility program.

 

* A shortcut to the Mentor License Utility is created under Start > Programs > Mentor Graphics License Utility

Average User Rating
(1 rating)

Bookmarked By (0)

More Like This

  • Retrieving data ...