Skip navigation

This Question is Possibly Answered

1 "correct" answer available (5 pts) 2 "helpful" answers available (4 pts)
1,409 Views 1 Reply Last post: May 23, 2012 9:29 AM by guy_wettstein RSS
kevin.memi Lurker 2 posts since
May 20, 2012
Currently Being Moderated

May 20, 2012 5:56 AM

Mentor ADMS compiling error

Hi all,

 

On our system (Ubuntu 10.10, X86_64 processor), Mentor ADMS 2010a version is installed following the manual. The process completed without any error. Then I try to test the installation phase by following command:

---------------------------------------

check_mgc_ams_home all

systest all

---------------------------------------

The result is PASS except a FAIL in complilation phase.

And then, I try co check the C compiler by:

---------------------------------------

amc -v

---------------------------------------

This raise a error: "Error: cannot find command: amc"

 

Finally, I try to compile a simple tutorial ADC-12 from Mentor, and the error is shown as below:

---------------------------------------

Compiling file adc12-ms.vhd

Compiling Entity Declaration multi_clock

Code generation for work.multi_clock

Compiling Architecture modelsim of multi_clock

Code generation for work.modelsim/multi_clock

Error: (vacom) While compiling file "adc12-ms.vhd":

Code generation failed for unit "modelsim/multi_clock" in library "work"

ARCHITECTURE modelsim/multi_clock deleted

---------------------------------------

Is is able to display the detail report of the error? It is meaning less to just a 1 line of error like this.

 

Strongly appreciate your help.

Waiting for any help.

guy_wettstein Mentor Graphics 59 posts since
Mar 10, 2009
Currently Being Moderated
May 23, 2012 9:29 AM in response to: kevin.memi
Re: Mentor ADMS compiling error

Kevin,

 

Unfortunately, Ubuntu is not a supported platform for ADMS. I can't say that is the cause but the ADMS environment uses numerous wrapper scripts to determine the machine type for locating the correct binaries and unsupported platforms often can't be mapped correctly. That could explain why amc can't be found. Have you tried this on a support platform?

 

The vacom error could be a symptom of the previous problem but looks like something that the product forum might help with.

 

Best Regards,

 

Guy

More Like This

  • Retrieving data ...

Bookmarked By (0)