• Full C++11 support in CodeBench for ARM GNU/Linux?

    Hello,   the latest version of Sourcery CodeBench Lite for ARM GNU/Linux (Version 2013.05-24) comes with GNU C & C++ Compilers 4.7.3. Unfortunately this version of GCC does not fully support the new C++11 s...
    stefan.muehling
    last modified by stefan.muehling
  • Two build errors creating a static library

    Hi again.   I'm receiving two IDE-related build errors when compiling my static library.   The first happens all the time but is fixed by deleting the file listed below:   Errors occurred during the b...
    Akin
    last modified by Akin
  • Removing a file from Project Explorer without deleting it in the file system

    Hi,   I feel kinda silly asking this as it should be a no-brainer, but how can I hide or remove a file from the Project Explorer without forcing a delete in the file system?   Basically, we have an in-hous...
    Akin
    last modified by Akin
  • How is uint64_t handled?

    I'm using the free Sourcery CodeBench to compile for ARM Cortex-A9 (specifically, the Xilinx Zynq processor) and my application uses variables declared as uint64_t.  My application works on a regular linux box, b...
    jschell
    last modified by jschell
  • Using Sourcery Analyzer

    Hi,   How to use Mentor Embedded Sourcery Analyzer tool? I wanted it to analyse CPU usage and for Performance analysis.   Could anyone help me out with this?   I am using Nucleus ReadyStart(Nucleus R...
    anand-k
    last modified by anand-k
  • Feature questions

    Hello  Everyone I could not find informations in the documentation about the following topics. I would appreciate is someone can point me to the appropriate document or provide me with indication on how to do. ...
    g.yvraut
    last modified by g.yvraut
  • gcov support in Sourcery Codebench IDE/code coverage analysis

    I want to do code coverage analysis of my application in Sourcery Codebench IDE.  I tried gcov, but couldnt do any trace. Is there a better way to do code coverage check? I am using Nuclues Readystart Sourcery C...
    anand-k
    last modified by anand-k
  • Connection problem with STM32F4Discovery

    Hello,   When trying to connect to the STM32F4Discovery board with Sourcery CodeBench IDE Version: 2013.05-26 and  debugger interface declared as "ST-LINK", I am getting the following message: "No devices f...
    g.yvraut
    last modified by g.yvraut
  • c++config.h missing

    The 16 May 2013 professional Code Sourcery IA32 GNU/Linux compiler for arm-none-eabi is missing the file include/c++/4.7.3/bits/c++config.h   This file is included from include/c++/4.7.3/utility   Also mis...
    mike18
    last modified by mike18
  • New to Sourcery Code Bench problems with stmf4 discovery board

    I'm probably doing something very silly but I'm having problems trying to connect to an stm32f4 discovery board with it's inbuilt ST/LINK V2 interface. However when I try to set the board as a target in Code ...
    mentor3
    last modified by mentor3
  • CodeBench Lite - ARM compilerproduce different object file for the same source file !!

    Using the GCC compiler for ARM (windows) : arm-none-eabi-gcc.exe (Sourcery CodeBench Lite 2012.09-63) 4.7.2 version I have got different object file produced every ~5 times i compiled the same source file. The opti...
    abdurahman.alfeky
    last modified by abdurahman.alfeky
  • codebench lite build error

    Hi,   while build project,I met an eror:     /bin/sh: -c: line 0: syntax error near unexpected token `(' /bin/sh: -c: line 0: `C:\Program Files (x86)\CodeSourcery\Sourcery_CodeBench_Lit e_for_ARM_EABI...
    aihua.zhang
    last modified by aihua.zhang
  • Problem in compiling hello world application

    Hi,   I am working on the project based on Marvel wmsdk development kit. I have downloaded and installed the toolchain arm-2012.09-63-arm-none-eabi.exe as mentioned in the requirements.   When trying to co...
    oamprakash
    last modified by oamprakash
  • TUI mode is not supported

    Hi All,   I am using Marvel development Wifi  board for development.   I am doing my testing on windows 7 under cygwin.   Downloaded code sourcery ARM EABI toolchain latest release : arm-2012.09...
    sxmuniswamy
    last modified by sxmuniswamy
  • Using Sourcery toolchain with uClibc

    I'm using Sourcery CodeBench Lite to compile for the Xilinx Zynq processor.  However, I need to be using uClibc instead of glibc.  Is there an easy way to recompile the toolchain so that I can do that? ...
    jschell
    last modified by jschell
  • Kernel build: CodeBench Lite (Win32) + Cygwin Fails

    Dear Sirs,   I have installed successfully your Sourcery CodeBench lite (2012.09.64) on a Windows Vista + Cygwin environment. The environment is carefully setup in such a way that it is case sensitive and fullf...
    Eman
    last modified by Eman
  • sscanf produces unhosted IO warnings

    Hi,   I am using codesourcery ARM EABI toolchain to build code for a energy micro cortex M3 (EFM32GG290F1024)   I can build and run code fine however calling sscanf seems to give me 4 warnings: "libcs3unh...
    grant
    last modified by grant
  • Bare-metal ARM Codebench Lite and C++ exceptions

    Hi all,   I am using the ARM bare-metal Codebench Lite toolchain on an embedded project. The code is written in C++, is multi-threaded and makes use of exceptions. My question is whether gcc has support for t...
    stathisv
    last modified by stathisv
  • Having problems with Sourcery linker loading Android libraries

    I have been using Sourcery Code Bench version arm-2011.09-70-arm-none-linux-gnueabi-i686-pc-linux-gnu.tar.bz2 to compile an application for Android.  This toolchain worked flawlessly for me in doing the compilati...
    roger_r_cruz
    last modified by roger_r_cruz
  • New project configuration

    Hi Everyone,   I am evaluating the Codebench Sourcery ARM, I'm used to using the Freescale CodeWarrior which creates the project with all the configuration files to use as the target microcontroller, the Sourcer...
    carlos.pichardo
    last modified by carlos.pichardo