PCB Forum 2015 – Question Log for xDX Designer

Version 1

    Q1: Is there a way to reprogram the ‘F1’ key?

     

    Check the keyboard mapping files in SDD_HOME\standard – these include exped_pv.vbs, exped_wvo.vbs, and vdbindings.vbs. You can open these files in a text editor to change the stroke commands and keyboard shortcuts.

     

    For the ‘F1’ key, you would edit the following line:

     

    Bindings("Application").AddKeyBinding "F1", "Help", Menu, Accelerator

     

    TechNote MG243993: Key Bindings File Names for DxDesigner (iCDB)

    TechNote MG33244: Adding Key Bindings in DxDesigne

    TechNote MG28026: Modifying the Key Bindings in DxDesigner

     

    Q2: When did the Setup > Settings > Project Backup dialog get introduced?

     

    This dialog box is the same as the iCDB Project Backup utility, which has been around from EE 7.9.2. The integration within xDX Designer took place in the EE 7.9.4 release.

     

    TechNote MG549408: iCDB Project Backup - Configuring iCDB Project Backup and Managing

     

    Q3: Are stroke commands available in xDX Designer only?

     

    They are available in xDX Designer and xPCB Layout. They are not available in PADS Layout, xDM Library Tools, HyperLynx, or Constraint Manager.

     

    TechNote MG586442: Strokes in xDX Designer

     

    Q4: Can we change the default settings for mouse buttons during cross-probing?

     

    No, you cannot change the mouse button functions. There are some limited cross-probing controls available in Setup > Settings > Cross Probing. You can modify the zoom, highlight, and selection settings.

     

    TechNote MG562866: Cross Probing Between DxDesigner and Expedition

     

    Q5: Has cross-referencing changed in VX?

     

    Scout (Tools > Cross Reference) has remained the same. Xref Annotations (Setup > Settings > Cross Reference) has also remained the same. One major improvement is that Tools > Update Annotations will no longer reset the annotation property’s location. The tool will preserve the location set by the user in the schematic.

     

    Cross-Referencing a Design, X-ENTP VX.1.1

    TechNote MG583566: Comparing Methods for Cross Referencing a DxDesigner Project (iCDB)

     

    Q6: If I set the ‘Cluster’ property on a Hierarchical Block, will it propagate down to all underlying components?

     

    No – you must set the property on the underlying components manually. This suggestion has been submitted as Mentor Idea D9101 – use the link to vote for this enhancement.

     

    Q7: Are there any improvements planned for Script Editor (e.g. a debugger, console window, etc.)?

     

    This has been submitted as Mentor Idea D8262 – use the link to vote for this enhancement.

     

    Q8: Are there plans to update the documentation for Automation with examples? At the moment it gives details on syntax, but no short examples of code usage.

     

    The documentation for Automation is being updated – check the details on Mentor Idea D14812.

     

    In the meantime, you may find it useful to check the ‘Examples’ directory within AATK – there are code samples in C#, Javascript, and VBscript. The Mentor Communities page also has an ‘Automation and Scripting’ section – check the Documents page to download scripts.

     

    Mentor Communities – AATK 1499 Release (VX and Linux Support)

    Mentor Communities - Automation and Scripting

     

    Q9: How can I keep cross-reference annotations from getting too long and blocking the schematic?

     

    If you are using Xref Annotations: this is enabled from Setup > Settings > Project > Cross Reference > Allow Condensed Annotations. Annotations will then be displayed in condensed format such as 1-A3/A4/A5 instead of the normal format 1-A3;1-A4;1-A5.

     

    If you are using Tools > Cross Reference (a.k.a. Scout): there are a number of condense, wrap, and truncate properties available. These include format_overflow, format_attr_length, format_condense, etc. Check the following document for specifics:

     

    Cross-Referencing a Design, X-ENTP VX.1.1

     

    Q10: is the upcoming ‘Color By Net’ feature forward-annotated to layout? We would like to have consistent power/ground/etc. coloring between schematic and layout.

     

    This has been submitted as Mentor Idea D3622 – use the link to vote for this enhancement. It also exists in some form through AATK – check the Draw > Color Net DX function. This will color nets in both xDX Designer and xPCB Layout – however, both tools need to be open.

     

    Mentor Communities – AATK 1499 Release (VX and Linux Support)

     

    Q11: Will Tools > Update Symbols override any Pin Types that were manually set in the schematic?

     

    No – setting the Pin Type in the schematic will create a Block or Instance Value that won’t get overwritten by the update function.

     

    Q12: Will Hierarchical blocks automatically generate the first parts of the ‘Cluster’ property? For example, if I have DEDICATED parent block containing a DDR3 child block, will 'DEDICATED/DDR3’ be automatically created for me on the underlying components?

     

    This is a great suggestion that hasn’t been submitted yet on Mentor Ideas.

     

    Q13: Does rotating circuitry maintain net avoidance?

     

    When you rotate or move a net it will not maintain the net avoidance defined within Setup > Settings > Nets. This suggestion has been submitted as Mentor Idea D12090 – use the link to vote for the enhancement.

     

    Q14: How do you toggle net names off for copied nets?

     

    Enabled from Setup > Settings > Advanced > Unique Names on Copy. You can also switch from the Command Line by typing ‘uoff’ or ‘uon’.

     

    TechNote MG542779: How do I turn on/off the Unique Label on Copy feature while working on a schematic without having to keep changing the setting in Setup->Settings?

    TechNote MG540571: Considerations When Copying Circuits in DxDesigner

     

    Q15: How do you toggle reference designators off for copied components?

     

    Enabled from Setup > Settings > Advanced > Preserve Packaging Info on Copy.

     

    TechNote MG545870: Preserve Packaging Info On Copy - New for DxDesigner 7.9.2

     

    Q16: How do you bring over Compound Symbols (rotated symbol views in one symbol file) for an entire library? Any documentation, guides, AppNotes would help.

     

    These are a planned enhancement for the VX.2 release, so materials are not available yet. Keep an eye for them out in the near future.

     

    Q17: DxDataBook - when using a wildcard in the filter (i.e. CON20*) does it screw up Live Verification?

     

    No, because Live Verification is a separate function with xDX DataBook.

     

    TechNote MG566507: DxTopics - DxDataBook

    TechNote MG522256: Using DxDataBook to Replace Schematic Components (iCDB)

    TechNote MG83475: Using the Update All Unique Matches Feature in DxDataBook

     

    Q18: Can I create a project-specific list of Favorites in the ‘My Parts’ pane? If so, how can I share this list with another person?

     

    Yes, you can do this by creating a copy of DxDesigner.xml in the project directory. The ‘Favorites’ section is populated from this file. If you open this in a text editor, you will see entries such as:

     

    <key name="TOOLBOX_FAVOURITES">

          <value>passive:resistor.1|R_0402_1%_10K0</value>


    To share with another user, send them the .xml file or just the relevant text.

     

    Q19: Can we import a Visio diagram into xDX Designer?

     

    You can attach the Visio document as an OLE object in the schematic through Add > Insert Object. However, xSD Systems Designer is needed to intelligently read & import a Visio drawing.


    xSD Systems Designer Users Guide - Importing a Visio Drawing

     

    Q20: How can we use DxArchiver to automate our project backup? We use Job Management Wizard right now.

     

    DxArchiver can be invoked within xDX Designer or from the command-line. The main advantage it offers over Job Management Wizard is that is can be used while the design is being worked on – checks, warns and shuts down open iCDB streams before archiving. The list of files it includes by default are covered in:

     

    TechNote MG518831: DxArchiver - What Files Does It Include

     

    You can add additional files by editing the configuration file manifest.xml. If you are using the GUI, there is a dialog in which you can select additional files.

     

    TechNote MG583230: Archiving Projects in DxDesigner

     

    Q21: How do we create component hyperlinks in the schematic (e.g. place an arrow icon on title page that will jump to a certain sheet)?

     

    You need to create an ‘ANNOTATE’ type symbol which has at least one pin defined on it (it can be non-functional, but the pin needs to exist). Set the symbol as a ‘Link’-type symbol from Setup > Settings > Special Components.

     

    Place the symbol into the first schematic sheet and give it a name in the Properties window. Then place another copy of the symbol on the second schematic sheet and give it the same name. You can now jump between sheets by ‘Alt’-clicking the symbol. If there are multiple sheets where it exists, you can use RMB > Jump to find the right one.

     

    DxDesigner Users Guide for Expedition Flow – Viewing Objects Across Multiple Sheets

    TechNote MG582971: Navigating Projects and Zooming Using Link Symbols with ALT+LMB

    Tutorial MG582678: Navigating a DxDesigner Schematic Using Link Symbols (iCDB)

     

    Q22: Where are the project backups for xDX located?

     

    By default, they will be in the project directory – check the ProjectBackup\backups folder. More specifically, your .PRJ file contains an entry which points to a configuration file:

     

    KEY ConfigFile ".\ProjectBackup\ProjectBackup.cfg"

     

    This configuration file in turn defines where the default backup location is:

     

    KEY StorageDir "./backups"


    You can modify the configuration file location & contents for your own specific needs.

     

    TechNote MG583658: Including Custom Auto Backup Schedule in Project Template

    TechNote MG582860: Specifying Default Folder for iCDB Backups