2 Replies Latest reply on Jan 10, 2019 4:08 AM by stempialdo

    how to export local symbol into central library

    stempialdo

      Hi there,

      I am using VX2.4 , update 2.

       

      Somehow my border symbol got corrupted in the central library (the symbol is still there in the library tree but it appears as blank).

      Luckily I have a Designer project that implements that border and so I can see the border in Databook - Symbol view (in the borders category).

      Within the design I am able to select that border and place it into the various design sheets (selecting it from the Symbol view, not from the central library).

       

      In the Designer's user guide at page 290 there is the export procedure for local symbols (right click and export as a file that is to be imported into the central library).

      However the "export symbol" option is greyed out for symbols that are not user-created in the design.

       

      Any clue?

       

      Thanks

      Flavio

        • 1. Re: how to export local symbol into central library
          robert_davies

          Export of symbols derived from the central library is not available as you note. But if you can still see the symbol in the Symbol View then you are still looking at the central library, so I don't really understand that statement.

          Anyway, one thing you could try it to copy the symbol file out of the library tree and then try importing this file back in to see if it fixes the issue. The symbol is just an ASCII file stored in the SymbolLibs folder tree. If the file is corrupted then you will need to recreate it or find a backup if you have made one.

          • 2. Re: how to export local symbol into central library
            stempialdo

            Hi Robert,

            thanks for your quick reply.

             

            Actually I could initially see the border symbol listed in the symbol View but then it disappeared from the list (I guess the view had to sync with the central library?). Anyway I'm still not sure why the border symbol got corrupted in the central library in the first place.

             

            For future reference, I managed to copy the symbol from Designer into the Symbol Editor exporting/importing as DXF.

            Hope this helps if somebody has the same problem.

             

            cheers

            Flavio