4 Replies Latest reply on May 7, 2013 5:47 AM by mathieu.lafrance

    Problem getting @printorder to work correctly with PDF printing

    mathieu.lafrance

      Hi,

       

      I'm having problems getting the PDF printer to work correctly. I've had it set up correctly for my first project, but I can't get it to work correctly with the second project. I've compared the .pjr files to see if a revelant setting was different, I also checked borders.ini, dxpdf.ini and scout.ini. Besides the usual name differences, they're identical. Both projects also share the same border symbols.

       

      On the "working" project, I get this output. All unique page numbers, in order:

       

      1.png

      On the non-working project, all messed up.

      2.png

       

      I don't think the problem lies with the PDF printer, because I can see a difference when "pushing" thru hierarchical blocks between the two projects. On the working project, when I push thru a block, I see this on "border property":

      3.png

       

      Notice how the page number is reflected correctly with the Instance Value.

       

      Now with the non-working project:

      4.png

       

      Notice how the page number isn't reflected correctly. The Instance Value doesn't even exist. Note that "?" is the default value of @PRINTORDER within the symbol editor.

       

      I've tried already "Update Other Objects" by checking "Properties" and "Print Order", with a combination of Project, board, schematic, sheet ... tried all of them. I also tried running scout with the same settings as the other project, to no avail. Packaging was also performed.

       

      What am I missing ?

       

       

      I've included a bunch of .ini and .prj files of the non-working project, if any of you can spot something.

       

      Thanks for any help provided.