5 Replies Latest reply on Oct 21, 2014 11:30 PM by agxinmj

    ERROR: Unable to locate CES pin

    mathieu.lafrance

      Hi,

       

      I'm getting a strange error when packaging for which I can't find any information. I'm getting a bunch of:

       

      ERROR: Unable to locate CES pin "R???-?" while  attempting to connect pin to net "?????"  in the CES configuration (I've replaced the actual ref des and net name with "??")

       

      I am unsure of how this relates to CES. Are we talking about the Constraints ? I think CES might need to be updated, but I can't see such options.

       

      If it's of any interest:

      This error started to appear after I was completed with fixing all the other errors that were present in the schematic. Actually, i'm fixing errors in this design because we got it from another team. We didn't get a full working library (all symbols were missing, but cells and parts were present), so I've been working on replacing parts with newer parts that had the original symbols so that we could package correctly.

       

      Included in this message is the full output of packager.

       

      Any ideas where I can start ?

        • 1. Re: ERROR: Unable to locate CES pin
          mathieu.lafrance

          I've tried running CES Diagnotics, a few errors came up, most of them are now fixed, but one type of error persists:

           

          Test: Pin  reference to net valid

           

          Error 3411: Pin seems to be  used more than once in components. Not  Fixed.

           

          There are 283 occurences of this error in CES Diadgnostic, exactly the same number of errors that i'm getting from packaging.

           

          Please advise.

           

          Thanks

           


          • 2. Re: ERROR: Unable to locate CES pin
            mathieu.lafrance

            Workaround as provided by mentor:

             

            I tried the following to work around the issue and it seems to work.  So try that and let me know if you still see any issue.  In the meantime, I am turning in a Defect on this issue to Engineering that CES Diagnostic should be able to fix this issue when ran. 


             

            I invoked CES from DxDesigner and ran CES Diagnostic and fixed any errors that could be fixed.  Then I closed CES and ran Tools > DxDesigner Diagnostic.

             

             

            Then I ran packager and the very first part in question was about R150. 

             

             

            Using Edit > Find dialog, I found R150 in the schematic.  Then enabling everything in the Filter, I area selected the whole schematic and hit delete on the keyboard.  You will get a message about composite symbols, click Yes anyway.   Now do Edit > Undo to get everything back.  Now close all schematic and run Packager again.  You will notice that at least the first few errors are taken care off and the next one seeing is for R426.  Do the same with this part, locate this part and delete everything from the schematic sheet it is on and then Undo.  You will have to try this a couple of times and then it should resolve the issue and hopefully Packager will run clean after doing a few more of these sheets.     

            • 3. Re: ERROR: Unable to locate CES pin
              eric.o.tavares

              Hi Dear Mathieu,

               

              It was very useful for me! Thanks!

              • 4. Re: ERROR: Unable to locate CES pin
                aclark

                I did this, and it did solve my "Unable to locate CES pin" error.

                 

                However, this MUST be used with caution.  As I found out, UNDO does not undo everything.  It only undoes the properties that are Block values or the current Instance.  I had to manually re-enter all the values for the other 28 instances .

                • 5. Re: ERROR: Unable to locate CES pin
                  agxinmj

                  hai

                            the same error i got when i replace the symbol especially  ceramic capacitor in a packaged schematic with polarized capacitor and if we choose preserve reference information after replacing when i package the schematic this error is appearing

                  so while replacing symbols we should be really careful and we should not apply cntl+z after replacing the symbol with equivalent symbols

                  as far as possible try to avoid Preserve reference designators