2 Replies Latest reply on Sep 26, 2013 9:45 AM by Akin

    Two build errors creating a static library

    Akin

      Hi again.

       

      I'm receiving two IDE-related build errors when compiling my static library.

       

      The first happens all the time but is fixed by deleting the file listed below:

       

      Errors occurred during the build.
      Errors running builder 'CDT Builder' on project 'Basics'.
      A resource already exists on disk 'C:\Perforce\Trunk\Tech\Code\Core\Basics\Debug\sources.mk'.
      A resource already exists on disk 'C:\Perforce\Trunk\Tech\Code\Core\Basics\Debug\sources.mk'.
      

       

       

      The second doesn't happen all the time, but a rebuild usually fixes it:

       

      'Building target: libBasics.a'
      'Invoking: Sourcery CodeBench Archiver'
      arm-none-eabi-ar -r  "libBasics.a" "@objs.rsp" "@user_objs.rsp" "@libs.rsp"
      arm-none-eabi-ar: creating libBasics.a
      arm-none-eabi-ar: @user_objs.rsp: No such file or directory
      cs-make: *** [libBasics.a] Error 1
      

       

      I created a new static library project with just one file and that seems to work consistently, so I'm not sure where the problem started. I've compared project settings and they both seem to be identical. I've clean and rebuilt, along with restarting the application. None of these seems to fix the issue.

       

      I also tried deleting the project, recreating it, and then building. This worked once, but the second build gave me the first error above. The only project settings I change are creating one symbol and adding two include paths.