3 Replies Latest reply on Oct 28, 2013 10:41 AM by MENTOR_Shannonk

    Deleting symbols from a library

    rlacovara

      How do I delete a symbol from a library?   I was told to delete it in Windows Explorer, but when I do, if I try to create a symbol by the same name, Symbol Editor tells me it already exists.

       

      Thansk for any help.

      -A

        • 1. Re: Deleting symbols from a library
          robert_davies

          If using Library Manager then use the context menu from the Navigator - Open the symbol partition and use the delete option on the Right Mouse Button. If using PADS or a third party netlist flow then from windows explorer as you have done and if DxDesigner is open when you do this refresh the library by either running Tools - Update Libraries or close and re-open the project.

          • 2. Re: Deleting symbols from a library
            rlacovara

            Sorry, no dice.

             

            Note this is for a Hetero 3 device.  I'm just trying to delete one of the fractures and then create a new one by the same name - the old one is currupt and Symbol Editor cannot open it. Here is what I did:

             

            1.  went to explorer and deleted all occurances of BANK_VCCINT.1

            2.  Tool/update libraries as you instructed

            3.  quit DxDesgner

            4.  started up again and tried to create a new libray symbol named BANK_VCCINT using Symbol Editor, get error message "Symbol BANK_VCCINT already exisits".

            5.  deleted main library "Xilinx_H3" and added it again

            6.  repeated sptes 2 - 4, problems persists.

             

            Any other suggestions?

             

            Thanks,

            -A

            • 3. Re: Deleting symbols from a library
              MENTOR_Shannonk

              Does it work if you give it a different name? One you haven't used before?