1 2 First Previous 23 Replies Latest reply on Aug 7, 2017 1:33 PM by istwok

    No Connect Symbol in ee7.9.5

    douglas.feck

      I created a no connect symbol and placed it in the builtin partition in the central library. I then tried to add it to the speccomp.ini file and can't see the symbol in 'Setup-Settings-Special Components' in DxD. I go to navigate to the symbol and there's nothing under the builtin partition when selecting 'No Connect Symbols' in the pulldown menu. I can add my no connect symbol as "PORT_IN" in the speccomp.ini and it shows up under the "Port IN" pulldown in the settings menu. What am I doing wrong?

       

       

      [PINCOMPONENTS]

      PORT_IN=builtin:in.1

      PORT_OUT=builtin:out.1

      PORT_BI=builtin:bi.1

      SHEET_PINS=builtin:onsheet.1

      SHEET_PINS=builtin:offsheet.1

         =builtin:NC.1           <=============== What should the first expression be?

      POWER_PINS=generics:userv.1

      POWER_PINS=generics:v15.1

      POWER_PINS=generics:v12.1

      POWER_PINS=generics:v3p3.1

      POWER_PINS=generics:v2p8.1

      POWER_PINS=generics:v2p5.1

      POWER_PINS=generics:v1p8.1

      POWER_PINS=generics:v1p5.1

      POWER_PINS=generics:v1p3.1

      POWER_PINS=generics:v1p2.1

      POWER_PINS=generics:vn15.1

      POWER_PINS=generics:vn12.1

      POWER_PINS=generics:vcc.1

      GROUND_PINS=generics:gnd.1

      GROUND_PINS=generics:agnd.1

      GROUND_PINS=generics:xgnd.1

        • 1. Re: No Connect Symbol in ee7.9.5
          robert_davies

          A 'No Connect' symbol should be of type 'annotate', it should also have a 'Term' property with no value attached to it, we ship one with the release (Basic:Term) so you could use this as the basis for your symbol. Also see the on-line documentation shipped with the software: Data and Library Management - DxDesigner Symbol Editor : Creating a No Connect (Terminator) Symbol . If the symbol is of 'annotate' type it will show up in the selection list for the No Connect pins, if it is of type 'Pin' it will show up in the list of symbols for Ports (hierarchical-in,out,bi).

          Note that these symbols are only used to terminate unconnectewd symbol pins, they do not work on buses or through hierarchy.

          • 2. Re: No Connect Symbol in ee7.9.5
            david.hughes3

            Hi Douglas,

             

            Our speccomp.ini line for our No Connect symbol reads:

             

            RWTERM=Symbols_Non_Elect:no_connect.1

             

            Hope this helps

             

            Dave

            • 3. Re: No Connect Symbol in ee7.9.5
              douglas.feck

              David,

               

              That's exactly what I was looking for! I researched this on SupportNet and was NOT successful in my research. I did not see were it shows to use RWTERM to get the list to show up in the special componets setup menu. As a matter of fact, there's really no details on SupportNet about speccomp.ini.

               

              Thanks again,

              Doug

              • 4. Re: No Connect Symbol in ee7.9.5
                robert_davies

                If you see the details in my previous post (I added some more info today) then you will see the reason why the symbol is not available for selection in the No Connect list and hence why it doesn't appear in the speccomp.ini. The speccomp.ini file is not intended to be hand edited, it gets populated from the Settings dialogs. Even if you add the correct entry in the speccomp.ini file, unless the symbol is the correct type (annotate) with the required properties (Term= 'no value') then it won't work as a No Connect symbol it will be treated as a hierarchical port.

                • 5. Re: No Connect Symbol in ee7.9.5
                  douglas.feck

                  Robert,

                   

                  I did create the symbol correctly as written/suggested by Mentor documentation. However, it did NOT show up in the list. I researched this for a few hours before submitting a support ticket and writing this discussion. The only way it worked is for me to hand edit the speccomp.ini. I know in theory it's suppose to work as you say however like every Mentor application it does not work. I've attached an image of my symbol property window. If I did something wrong then please correct me.

                  Symbol Editor - Library  XMGCdx_library7.jpg

                  Doug

                  • 6. Re: No Connect Symbol in ee7.9.5
                    robert_davies

                    Can you attach the symbol to this thread or send it directly to Mentor so that we can determine if there is a bug with this? One thing you could try is to see if the basic:term symbol appears in the Settings - Special Components dialog. We can then do a comparison with the shipped symbol and yours.

                    Rob

                    • 7. Re: No Connect Symbol in ee7.9.5
                      roger.alexander

                      Hello Robert, Would you mind telling me how to get the "Term" property into my NC symbol? It isn't available in the dropdown. I know that this isn't a common property but I don't know how to get it added my symbol. Also, is there a way to suppress single pin net warnings for the NC symbol? I added the NC symbol that is in the builtin library but it does not suppress single pin net warnings.

                       

                      Thank you,

                       

                      Roger

                      • 8. Re: No Connect Symbol in ee7.9.5
                        robert_davies

                        Are you running Expedition or PADS? In the PADS flow the No Connect symbol doesn't apply. If you are running the Expedition flow then the Term property should be in your property file as property number 677, see attached. If it doesn't appear then ensure the property definition file is up to date by opening the Central Library in Library Manager. This should ensure the latest version of the property file is being used, though the Term property has been in the flow since the 2007.8 release. You can always copy the Term symbol shipped with the install in the basic library and edit that to suit. You can find a copy in the sample library we ship:

                         

                        'install directory\SDD_HOME\standard\examples\SampleLib2007\SymbolLibs\builtin\sym\term.1

                         

                        Use library manager to copy the symbol from here to your central library 'File - Import Symbols'

                         

                        Also ensure you are using it correctly, the no connect symbol is only used to terminate pins on PCB parts, so symbols of type 'Module' it does not work through hierarchy.

                         

                        I've checked and created a new 'No connect' symbol in EE7.9.5 without any issues.

                        • 9. Re: No Connect Symbol in ee7.9.5
                          roger.alexander

                          Thank you for the information Robert. Is there a way to supress the single pin net warnings that are generated by the no connect symbol? It makes it more difficult to find the actual single pin nets that aren't legitimate.

                           

                          Thanks again,

                           

                          Roger

                          • 10. Re: No Connect Symbol in ee7.9.5
                            robert_davies

                            Suppress the messages where? Th No Connect symbol prevents the Single Pin net warning in the packager, see attached, and the unconnected pins warnings in DxDesigner Verify.

                            • 11. Re: No Connect Symbol in ee7.9.5
                              MENTOR_Shannonk

                              Are you running Tools > Package or Tools > PCB Interface?

                              • 12. Re: No Connect Symbol in ee7.9.5
                                roger.alexander

                                Hello Shannon, how do you execute Tools, Package? This is not available in my dropdown. What am I missing?

                                 

                                Roger

                                • 13. Re: No Connect Symbol in ee7.9.5
                                  robert_davies

                                  Then that explains why this doesn't work for you. What PCB tools are you exporting your net list to? If you use the net list flow then the No Connect symbols don't work, as I intimated in my first response.

                                  Rob

                                  1 2 First Previous