8 Replies Latest reply on Jul 11, 2014 7:41 PM by hain

    Modelsim running error - Fedora 20

    rodaumm

      Hi guys, i just installed fedora 20 and Quartus II 13.1 with Model Sim Starter Edition.

      I downloaded all required packages, but when i try to run modelsim, it shows me this msg:

       

       

      [root@localhost Downloads]# vsim

      Error in startup script:

      Initialization problem, exiting.

      Initialization problem, exiting.

      Initialization problem, exiting.

          while executing

      "EnvHistory::Reset"

          (procedure "PropertiesInit" line 3)

          invoked from within

      "PropertiesInit"

          invoked from within

      "ncFyP12 -+"

          (file "/home/rodrigo/altera/13.1/modelsim_ase/linux/../tcl/vsim/vsim" line 1)

      ** Fatal: Read failure in vlm process (0,0)

       

      I tried to reinstall and sam thing happened. I tried downloaded Quartus 13.0 and same thing occurs.

      I read in a ArchLinux forum that maybe it is a problem with an update on freetype package, but i just dont know how to fix it.

      Somebody knows what this is?

        • 1. Re: Modelsim running error - Fedora 20
          uros.stevanovic

          I have the same error in opensuse 13.1, with the modelsim 10.1b.

          I've installed freetype 2.4.7 version(default is 2.5.0), to make it the same as in opensuse 12.1, where modelsim 10.1b starts without any problems, and still it didn't help.

          I am able however to start the modelsim in command line mode, but I need to be able to see the waveform, otherwise it's not that useful.

          Also it is not good that this error is not verbose enough, and doesn't indicate what is the error.

           

          So any idea? Does anyone else has the same problem? The solution to this problem would really be helpful.

          • 2. Re: Modelsim running error - Fedora 20
            uros.stevanovic

            I found a solution, actually a colleague of mine did.

             

            I've installed the freetype library in the /usr/local/lib64, while modelsim was still looking for it in the /usr/lib64, where the default one( version 2.5.0) was still there.

            The workaround is to use LD_PRELOAD="library2.4.7" vsim, when calling vsim. This could be put as an alias. The folder for new library could be in the same installation folder of the modelsim itself, for example. This is better than completely removing the default freetype library, since other applications may depend on it.

            With this, the modelsim works, and it can be used regardless of the Linux OS distribution (suse, fedora, archlinux...).

            • 3. Re: Modelsim running error - Fedora 20
              twagner

              I'm having the exact same issue with fedora 20 and modelsim 10.1d.  Can you elaborate a bit on your workaround?  I can see that I have libfreetype6 but I'm not sure what you did to get the thing running?

              • 4. Re: Modelsim running error - Fedora 20
                uros.stevanovic

                It appears that modelsim10.1 is not compatible with the newer versions of the libfreetype6. The steps for a workaround would be:

                - download earlier version of the libfreetype6, the one I've tried and seems to work is version 2.4.7.

                - compile, but don't install it globaly (i.e. don't run make install at the end), since there may be applications that depend on the default version.

                - when invoking modelsim (usually with the vsim command), new library needs to be preloaded, i.e. LD_PRELOAD="location_of_the_installed_library" vsim. For me, it looks like this:LD_PRELOAD="/opt/modelsim10.1b/libfreetype/libfreetype.so" vsim, where I made new folder called libfreetype in /opt/modelsim10.1b/ and copied the compiled library there (libfreetype.so). Of course, it can be placed in any folder.

                 

                This problem only affects the modelsim running in GUI mode, since that is when the libfreetype6 library is used.

                 

                I hope this answers your question.

                 

                Uros

                 

                P.S. I've since found that vopt is causing problems, but this is probably unrelated to the libfreetype6 library, but it is somehow related to the OS version. But this probably should be addressed in a separate thread.

                • 5. Re: Modelsim running error - Fedora 20
                  maswabey

                  I wrote a blog post http://mattaw.blogspot.com/2014/05/making-modelsim-altera-starter-edition.html which describes the process on Ubuntu however the last section on tweaking modelsim only to use an older version of libfreetype should work in Fedora without any changes apart from getting the build dependencies. yum-builddep is probably what you are looking for.

                   

                  Hope this helps,

                   

                  Matthew

                  • 6. Re: Modelsim running error - Fedora 20
                    guy_wettstein

                    Please keep in mind that neither Fedora or Ubuntu are supported platforms for ModelSim. You can check supported platforms for all Mentor products on SupportNet under System Requirements.

                     

                    Best Regards,

                     

                    Guy

                    • 7. Re: Modelsim running error - Fedora 20
                      hain

                      @uros.stevanovic: your solution is not good enough. I found troubles when running this command: vsim -c top. It returns a lot of error.

                      I think adding LD_LIBRARY_PATH in the /path/to/mentor/vco file is a better solution. vsim returns no error and works properly.

                       

                      Reference: http://mattaw.blogspot.com/2014/05/making-modelsim-altera-starter-edition.html

                      • 8. Re: Modelsim running error - Fedora 20
                        hain

                        Here's some additional settings to run questasim on Fedora 20

                         

                        1. In .bashrc, setup as following

                        export PATH=/usr/mentor/questasim/bin:${PATH}

                         

                        2. Edit vco file in questasim installtion folder.

                        vi /usr/mentor/questasim/vco


                        - Search for unknown keyword and replace it with linux_x86_64 (if you run on 64-bit machine) or linux (if you run on 32-bit machine)

                        - Search for dir=`dirname $arg0` and add the following line

                        export LD_LIBRARY_PATH=/path/to/libfreetype2.4

                         

                        3. Open new terminal and start vsim.

                         

                        Good luck!!!