1 Reply Latest reply on Jul 15, 2014 8:12 AM by greg.hall

    Resistor value is displayed incorrect on schematic

    greg.hall

      I have a 2.2 MEG Ohm resistor which I place on my schematic.

      When I then package the schematic it is displayed as 2m2 (which is 2.2 milliohms)

      I need it to remain and display as 2M2 (large M)

       

      I have other high value resistors 1.5 Meg Ohm and 10 Meg Ohm, when these are placed on the schematic they appear correct as 1M5 or 10M.

      It appears to only be the 2M2 Resistors that has a problem.

       

      Units display with library manager is set to European.

       

      Is there some local setting within the design which is causing this error.

      This is on a Expedition/DxDesigner flow version 7.9.1 design.

       

      Additional information;

      I have tried adding the same part to a different design and the value displays correctly as 2M2.

      The problem does seem to be related to the one design but how do I correct it for that design.

      Attached is a picture which shows the same component on two different designs one with the correct value shown (2M2) and one with the incorrect value shown (2m2).

       

      Any ideas how to fix?

       

      Message was edited by: greg.hall

        • 1. Resistor value is displayed incorrect on schematic
          greg.hall

          In order to answer this question I raised an SR with Mentor Graphics.

          Don't know why it has happened but to fix it was the following procedure.

           

           

          Exit from the design and open Library Manager on your central library and under Setup > Units Display, temporarily set the Electrical Units to ‘Scientific’. OK out of the menu and exit from Library Manager.

           

          Open the DxDesigner project again and run the Package routine with the ‘Update PDB Properties on Symbols’ option enabled. This should result in your values changing to Scientific notation.

          Exit out of DxDesigner and go back to the library and change the Electrical Units back to ‘European’. Relaunch DxDesigner on your project and again Package with the ‘Update PDB Properties on Symbols’ option enabled. This should result in your values changing to 2M2 European notation.

           

          This does work.