4 Replies Latest reply on Mar 10, 2015 9:06 AM by sdonaldson

    defaualt Visible properties

    sdonaldson

      I'm still new to DxDesigner/DxDatabook/PADs, using version 9.5.  How do I make certain properties visible by default when you drop a component on the schematic?  When I created the symbol, I placed Device, RefDes, and Value and had them visible.  When I drop it on my schematic, only the RefDes is visible.  There has to be a better way than to select every component and checking device and value every time I lay down a symbol.

       

      Thanks!

        • 1. Re: defaualt Visible properties
          robert_davies

          If you created the symbols as you state then all the properties should be visible providing they have values assigned to them. A couple of things to check:

          1. Do the properties have values to be shown as visible, as Ref Des is showing up, perhaps the other two are empty.

          2. Did you make changes to the symbol and the property visibility after you'd initially placed any in the schematic - if so you will have to update the symbols to accept the latest changes - Tools - Update Symbols (also if you find this is the case turn on Flag out-of-date symbols in the Advanced section of your settings to be notified when a symbol has been modified in the library).

           

          Failing these two suggestions provide a picture of the symbol in the library and the property settings to see nothing else is missing.

          • 2. Re: defaualt Visible properties
            sdonaldson

            For the resistor, RefDes had R? and the other two were blank. I updated one of the symbols to have all three non-blank, ran the update symbols, and no change.  I've been adding unique parts, as I am copying another schematic and already know what I'm going to use.

             

            Symbol Editor:

            Symbol Editor.jpg

            DxDesigner:  Both symbols below were placed after above was changed, saved, and Tools-Update Symbols.

            designer.jpg

            • 3. Re: defaualt Visible properties
              robert_davies

              Looks like the issue is with your DxDataBook settings, look at the configuration in DxDataBook from the right mouse context menu and ensure the VALUE and DEVICE entries have 'value visible' set. See attached.

              BTW< No need to add Device? or Value? in the symbol now we think we've figured out what is wrong, and you can also remove the PINOFF property (it was used to make discrete device pin numbers invisible).

              1 of 1 people found this helpful
              • 4. Re: defaualt Visible properties
                sdonaldson

                That looks like it works.  I feel a bit stupid now... I was just in there messing with the settings for the value magnitude earlier this morning.  Thanks!