4 Replies Latest reply on Aug 6, 2015 3:08 AM by kbak

    RefDes are gone on top assembly layer

    andrewz

      Hi,

       

      Somehow i have managed to loss all my RefDes on my top assemble layer.  I have toggled colors in the Display Colors Setup menu and i cant get them back.  Is there a way to toggle RefDes outside of the Display Color Setup Menu?  Can i reset their visibility somehow?

       

      Thanks

        • 1. Re: RefDes are gone on top assembly layer
          yan_killy

          Hello,

           

          I am not sure where they are in your design, however make sure Ref. Des. column have a check mark in Display Color Setup. Next assign different color to Ref. Des. for Top layer (1), Silkscreen Top (26), Assembly Drawing Top (27) and see where they will show up. The number I reference to are default numbers in PADS and may vary if modified them.

           

          Regards, Yan

          • 2. Re: RefDes are gone on top assembly layer
            andrewz

            Hi Yan,

             

            I tried toggling all of those setting and they didnt come back.  I am getting them to come back by selection each part and adding new label to each one.  Im not sure what i did to make them go away but im bringing them back 1 by 1.

             

            -Andrew

            • 3. Re: RefDes are gone on top assembly layer
              sravankumar.padarthy

              Andrew,

               

              you can select all the components which does not have refdes and you can generate refdes in one single step from properties-labels.

               

              for the missing refdes, select a component(which does not have refdes) go to labels under properties and select a refdes which is already available in the dropdown list and check if the show is set "none" or "value". if it is set to "none" change it to "value" to get you refdes back.refdes.png

              • 4. Re: RefDes are gone on top assembly layer
                kbak

                Hi

                We also see this error from time to time.

                We haven't figured out exactly why this error occurs, but sometimes it seems to occur if the 'BaseOption' in Assembly Variants for some reason get all the components marked as 'Not Installed'. I know it sounds weird by that's the closest we can get to the cause for this error.

                Sometimes it can be solved by just closing PADS Layout and reopen it again. Other times we need to add the RefDes labels by using the slution described by sravankumar.padarthy.

                regards

                Klaus