6 Replies Latest reply on Mar 30, 2016 2:02 AM by lgalantai

    Unable to re-edit an old design

    lgalantai

      Hi!

       

      I recently got a job to modify an existing PCB. However the design is so old, we don't have the database file used for it, thus I can't do a forward annotation. Is there a way to modify such designs? I would have to add some components too, I can modify the existing routing, but that's not necessary. I've attached some pictures for better understanding.

       

      FWA_error.JPG

      FWA_error_log.JPG

       

      Thanks!!
      Best regards!
      Laszlo

        • 1. Re: Unable to re-edit an old design
          j.welzel

          Hallo Laszlo,

          ..... difficult  -> but perhaps helps the following Setting

          I wish you success

          Jo

          • 2. Re: Unable to re-edit an old design
            lgalantai

            Dear Johannes,
            Thanks for the response, but I've already tried that, no luck..

             

            Regards,
            Laszlo

            • 3. Re: Unable to re-edit an old design
              herbiemama

              Hello Laszio,

               

                 Are you saying you don't have the schematic for this layout? If so you can try to change it to a netlist driven design. In the pcb/logic directory there is a file netlist.aug. You can change this to netlsit.kyn and then edit your project file so that the layout is driven by the netlist. If you don't have the library you can attach any library but will not be able to draw any data from it.

              • 4. Re: Unable to re-edit an old design
                lgalantai

                Steven!

                 

                I have the schematics for this design, but if I attach our current library to the design it doesn't find any of the components used in it, because these parts doesn't exist in the current library we use, so I get the message you can see above, if I try to forward annotate the schematics to the layout. As you can see on the second picture it says there are a few parameters missing in every component. If I try to add these parameters to the components and fill them with something, obviously it says that there are no such value in the parts database. I guess it wants to associate the symbols with the "part number" parameter, but the part number parameter is not even added to the components. I don't really understand why can't it use the local library it has in the source folder.

                 

                Thanks!

                Laszlo

                • 5. Re: Unable to re-edit an old design
                  Vern_Wnek

                  Unfortunately guys, I do not think this can get solved on the community as there are quite a few variables.

                   

                  I suggest filing a service request in SupportNet and someone can look into the issue in more depth with you.

                   

                  Thanks , Vern Wnek

                  • 6. Re: Unable to re-edit an old design
                    lgalantai

                    Would be great, but unfortunately the company I work for doesn't have access to SupportNet currently...

                     

                    Thanks!

                    Laszlo