7 Replies Latest reply on Jul 21, 2016 3:06 PM by v.placier@wanadoo.fr

    Custom Anti-pads Not Working!

    rflowers

      I need help getting the tool to use my custom anti-pad settings within each padstack.

       

      I normally have the toggle 'use design rules for thermals and antipads' (inside Options > Split/Mixed Plane) turned on when designing a board in PADS, thus any custom anti-pad settings inside the pad itself get ignored (the way I want it to be).

       

      However, in this design, I have a need to have a custom anti-pad setting for a square anti-pad.  So, I would think no problem, I just turn off (don't check) the toggle 'use design rules for thermals and antipads', and set my custom anti-pad settings, and the system will use them.

       

      I set the anti-pad settings within SETUP > PADSTACKS to what I want (a 49 mil square anti-pad on inner layers for a particular padstack).  I am using plane areas and not copper pours.  But, when I run the plane area, it is not seeing the custom square anti-pad.

       

      There has to be some setting that is not setup right.  What am I missing?

       

      Thanks

      Randy

       

      Here are some screenshots

        • 1. Re: Custom Anti-pads Not Working!
          David Ricketts

          Sorry for being obvious, but are the layers defined as split/mixed?

          • 2. Re: Custom Anti-pads Not Working!
            rflowers

            No problem being obvious.  Yes, they are split/mixed.  They have to be or you can't use a plane area for the planes.

             

            Randy

            • 3. Re: Custom Anti-pads Not Working!
              rflowers

              My company had to discontinue our Mentor service agreement, so this forum is my only means of solving this question (can't call Mentor Support anymore), help!


              Randy

              • 4. Re: Custom Anti-pads Not Working!
                jduquette

                You can also post here to get a more experienced audience (the old coots!) - Yahoo! Groups

                • 5. Re: Custom Anti-pads Not Working!
                  wcowles1

                  Randy,

                  Hope you found the answer by now but here is another possibility. Anti-pad shape is lost under copper to drill setting. Copper fill is using largest of two.

                  William

                  • 6. Re: Custom Anti-pads Not Working!
                    rflowers

                    I figured it out.

                    All i had to do was to turn on 'Remove Unused Pads', then the custom anti-pad works (assuming you are using plane areas and don't have the 'use design rules for thermals and antipads' toggle checked)

                     

                    Randy

                    • 7. Re: Custom Anti-pads Not Working!
                      v.placier@wanadoo.fr

                      Hello Randy,

                      You have posted your message on 16 June 2016 as I see, and it still "no resolved" (?)

                      We are on 21 07 2016......I'm afraid suddenly....

                       

                      I suppose you forgot (so I do) to "apply" after changing selection in the split/mixed plane tab.

                      I procede as follow

                      - run pour manager,and open setup from this menu,change for my configuration and.....APPLY !!!!!

                      then run pour manager for copper pour and mixed plane.

                      Here some images and comments for example with differents configurations.

                      Hope it could help you if not too late !!!

                      have a good day/Bonne journée.

                      Vincent.

                       

                       

                      1°) Use design rules = selected

                      Remove unused = unselected

                      Don't forgot to apply,then start flooding.

                      You can see default PADS flooding for all pads:

                       

                      Use design rules selected.jpg

                       

                       

                       

                      2°) Use design rules = unselected

                      Remove unused = keep unselected

                      Don't forgot to apply,then start flooding.

                      You can see your spécific values for antipad (B13,C15 have differents values for anti-pads and thermals)

                       

                      Use design rules unselected.jpg

                       

                       

                       

                       

                      3°) The option "Remove unused pads" do not affect your spécific anti-pads values,

                      this fonction remove only pads witch are not connected to any net,

                      since they don't have electricals fonctions they may be suppressed from the inner layer.

                      The advantage of this option is that you get more space to surround inner pads if you need for very fine

                      pitch or get more isulation in some cases.

                      (In real life,it seems to be preferable to keep them for more mechanical integrity,so I only modify inner pads diameter if needed)

                      In this case,(of using Remove unused pads) the insulation is recalculated from the edge of the hole.

                      here an example:

                       

                      Use design rules unselected-and-select-Remove-Unused-pads.jpg