6 Replies Latest reply on Nov 3, 2016 12:04 PM by johnduquette

    Invisible Title block

    Wayne

      Hello all,

      So this is a recurring problem that I first encountered many revisions ago and yet still pops up from time to time.

       

      I'm finishing up a design and am placing the title block and other fabnotes in preparation to sending it to a board house.  In reviewing the fab notes I see a "ghosted" image of the title block in a random place.  Some particulars:

      - I don't see it in the normal view of the board.  (the normal, working view of the design)

      - Doing CTRL/ALT/E (move view to extents) does not show it.

      - Zooming out as far as I can, using select anything (or shapes or documentation) does not allow me to select it.

      - When I preview the CAM files the shapes show up in the preview window.

       

      What I've tried:

      - Exporting as an .asc and re-importing.  Often this prompts the hidden "stuff" to show up..no dice.

      - Opening in blazerouter, often will give same results.  Again, no dice.

      - Opening in blazerouter, doing the select anything (or shapes or documentation) does not allow me to select it either.

       

      The software won't actually allow me to run the CAM files because I get an error message, "plot is too large for plotted area".

       

      Any help would be appreciated.  Thanks in advance.

      Wayne.

        • 1. Re: Invisible Title block
          Wayne

          I've added a Screen Shot of what I see in the CAM setup preview window.Whackiness.JPG

          • 2. Re: Invisible Title block
            johnduquette

            I'm guessing your CAM output is set up for centered.  Is there some stray element on a layer down in the lower left corner?  I had a similar thing happen in Logic when one of my generic components had something mis-defined far away from the component. 

            • 3. Re: Invisible Title block
              Wayne

              No, that's not it in this case.

               

              The title block you are seeing is phantom, it doesn't show up until I look at the CAM previews.  What you are looking at in the picture is layer 1.  The title block is the object I'm trying to get rid of but can't see or select or do anything with.

               

              On the drill drawing there is another title block (which is the one I want).

               

              So the issue is, what you see in the picture is what I'm trying to select and delete but can't do so.

              Thanks,
              Wayne.

               

              ***Quick update***

              the phantom/unwanted title block is waaaaaaaay out of the selectable range.  So I can't select it because it's so far outside the range it won't even get close.  So does anyone know of a way to increase the working screen range?  So in other words, if I zoom all the way out, I need to be able to scroll the screen to the right more than it currently allows me to.  Is there a way to adjust that?

              • 4. Re: Invisible Title block
                johnduquette

                So it seems like your Layer 1 CAM setup is referencing the drill drawing layer.  You can check that in the CAM setup.  I like to export the CAM setup and check it there to see what Layout says it is doing.

                Something like this:

                DOC_LAYER_NAMES Top

                DOC_LAYER_NUMBERS 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

                DOC_LAYER_TYPES Component

                DOC_FABRICATION_LAYER_NUMBER 1

                 

                Instead of this: 

                DOC_OUTPUT_FILE dd.pho

                DOC_LAYER_NAMES Top Drill_Drawing

                DOC_LAYER_NUMBERS 1 24 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

                 

                Side question - How come the preview only shows the titleblock and nothing on the top layer?  That may be a clue. 

                • 5. Re: Invisible Title block
                  Wayne

                  John,

                  It's not a layer setup issue....I can assure you of that.  Over the years I've noticed that from time to time when I take an object from the drafting library and go to place it on the design it mysteriously never shows up.  I go through the same process again and it then shows up.  However, when I run the CAM files the mysterious "unplaced" object (in this case a title block) shows up in the CAM files...but ONLY in the CAM files.

                   

                  Usually  I run through the steps I outlined in the first post and I'm able to get rid of it.  But in this case I can't.  I've since discovered it's because the title block is SO far outside the working area that I simply can't select it.  I've attached a SS of the drill drawing to show you what I mean.  In the lower left corner is the actual block and design work.  The full title block you see is the one I'm trying to get rid of but can't select.

                  Whackiness 2.JPG

                   

                  I hope you see/understand the issue I have.  Again, the full title block you see here (upper right) is not wanted.  However, I can't select it because it's outside the selectable area.  It also appears on all layers.

                   

                  Again this is not a new issue with PADs but I've always been able to deal with it one way or another.  In this case I'm at a loss for how to get rid of it.

                  Wayne.

                  • 6. Re: Invisible Title block
                    johnduquette

                    I've had parts disappear like that too.  How about this: 

                     

                    ASCII-out your design (that has the good and the bad)

                    Save a copy of your design.

                    Delete all the 'good' stuff (what is supposed to be there).

                    ASCII-out (this will be the 'bad' stuff) and see if you can determine the coordinates of the phantom titleblock; they'll be some ridiculously large numbers.  Then you'll know what to edit out of the original ASCII file.

                     

                    The editing may be a pain.  I'd use BeyondCompare to bring the two files up side by side and make it a fairly simple deletion.