4 Replies Latest reply on Mar 5, 2017 5:14 PM by malgumhasan@gmail.com

    Why the GND is visible for 2 layer design?

    malgumhasan@gmail.com

      Hi Sir,

       

      I am facing an error while practicing the reference design of  DLP-2232M-G  board  downloaded from this website.

       

      The design engineer of this board has been used 2 layer (TOP and BOTTOM ) keeping 3 to 21th layer inactive.

      Take a look " layer setup", in both case he assigned GND at "Assign Nets".

      two_layer.PNG

       

      After I made schematic in PADS logic and connect with PADS layout, I found GND trace on PADS layout design.

      Take a look, 2 capacitors ends are shorted, they are "GND". In this design, no layer for "GND" has been called.

      gnd_trace.PNG

       

       

      Kindly, tell me what should I do and whats wrong am I doing!

      If you feel any setting is necessary in "Design rules", let me know.

       

      Thank you.

        • 1. Re: Why the GND is visible for 2 layer design?
          johnduquette

          Because GND is an assigned net, the GND connections will be made when you <Tools><Pour planes...>.  Depending upon which version of Layout you are using you may need to select the planes option.  Then you'll see something like this: 

           

          (thermals are set to flood-over in this example)

          1 of 1 people found this helpful
          • 2. Re: Why the GND is visible for 2 layer design?
            malgumhasan@gmail.com

            Dear Sir John,

            Thank you very much for this response. You have nicely picked up points.

            Take a look my feedback on your comments.

            the GND connections will be made when you <Tools><Pour planes...>

            This is PADS 9.5 version, where I can find <Tools><Pour planes...>? Dont you mean Tools>Pour Manager like this drop down list?

            pour_manager.PNG

             

             

            If so after choosing plane (top/bottom) from left corner drop-down list of PADS layout , "copper pour " should be select from "drafting toolbar"  and need to fence around "board outline"/ "Layer plane" and press to  "flood". In pour manager window, things can be done in similar way. May be its far away from this topic.

            Depending upon which version of Layout you are using you may need to select the planes option

            If you can see the layer setup on previous post, split/mixed plane type has been selected. Any mode-less command you know?

            In Tool>options setting, reference design says,

            split_mixed.PNG

            What would be mixed plane display?

             

             

             

            (thermals are set to flood-over in this example

            Yes, take a look the Options,

            thermals.PNG

             

             

            This 2 link  could give us some idea, isnt it?

            pcb - What are the advantages of having two ground pours? - Electrical Engineering Stack Exchange

            pcb - Should vias be used for every GND connection? - Electrical Engineering Stack Exchange

             

            Thank you very much, kindly post your comment here.

            • 3. Re: Why the GND is visible for 2 layer design?
              johnduquette

              Yes, 'Pour Manager...'  my fingers weren't waiting for my brain...  In V9.5 I believe you need to select the 'planes' tab because the 'copper pour' tab is shown by default.  In VX they put it all on one tab. 

               

              After you pour, You can use SPO (split plane outline) to show only the outline of the mixed plane and SPD (split plane display) to show the filled shape again.  For copper pours the commands are PO and PD, respectively.

               

              <Help><Modeless Commands> gives a list but there are a lot to sort through; they are really handy once you learn them all.

              1 of 1 people found this helpful
              • 4. Re: Why the GND is visible for 2 layer design?
                malgumhasan@gmail.com

                Dear Sir,

                I do appreciate your instructions.

                Sudden tricks came in my mind, that was very common setting.

                 

                To invisible GND tracks, View>Nets> View nets dialog box will appear, select GND from the net list and add it in View list.

                After that, uncheck the View Details ( Trace plus the following unroutes ) option.

                1 of 1 people found this helpful