4 Replies Latest reply on Nov 17, 2017 7:57 AM by Alex_Grange

    "Not a valid 3D model" - Error

    tomer-tracepcb

      Hi

      I installed recently Xpedition VX 2.2

      I'm trying to add 3D model for some parts and I get an error that it's not a valid 3D model.

      when I'm trying to do it on another computer it works well without any problems.

      Do you have any idea why it's not working on my computer.

      Thanks

        • 1. Re: "Not a valid 3D model" - Error
          cathy_terwedow

          Hello, Tomer. I've moved your question to the Xpedition community where it should get a quicker response. Best regards, Cathy

          • 2. Re: "Not a valid 3D model" - Error
            charles.ietswaard1

            I have had the same error, and what worked for me was opening the step file in a MCAD package and export it again to a stepfile with a new name.

            After that, the newly generated package could be imported into VX. Make sure you save the stepfile in AP2014 format.

             

            Apparently there is something in the step file that VX does not recognize.

            • 3. Re: "Not a valid 3D model" - Error
              ronny.graumann

              Same behavior with my VX2.2 installation. Same model files that could be imported (igs or stp) under VX1.2 without problems can't be imported anymore under VX2.2 ("not a valid 3d model")

              Something's not working right obviously...

              • 4. Re: "Not a valid 3D model" - Error
                Alex_Grange

                Hi Ronny,

                 

                The tool is working as expected. The problem is the model itself. What we noticed in VX1 is that users were able to add 3D models in Xpedition that would cause downstream issues. These 3D models are faulty and have open faces. For example, in one case when you have a body that has an opening in the extrude the STEP export out of Xpedition will not know where the model starts and where it ends, therefore a boolean merge will occur and certain items can be misinterpreted. In VX2.0 we enforced consistency checks. If there are issues with the model then we will prevent the model from being added. These really need to be modified in a MCAD tool to resolve. In Charle's case it seems that the outputted step model was really not compliant to the STEP protocol. I know a particular major MCAD vendor where they were not exporting the STEP file correctly, which would have caused your his issue. Thats why simply taking it into a new MCAD package and saving it resolved his issue, but if the model has faulty faces they need to be cleaned up before being imported.

                 

                Regards,

                Alex

                1 of 2 people found this helpful