3 Replies Latest reply on Nov 10, 2017 6:35 AM by wcowles2

    via-to-copper clearance overruled by drill-to-copper clearance


      In PADS Layout, I want to set via-to-copper clearance to 8 mils and drill-to-copper clearance to 10.5 mils.


      But when I do this, when copper flooding the planes, around the vias the copper stays 10.5 mils away.


      Why is via-to-copper clearance allowed to be overruled by drill-to-copper clearance? What then is the purpose of via-to-copper clearance? Is there a time when the via-to-copper clearance is expected to be larger than the drill-to-copper clearance? I have never seen that happen.


      What I was thinking is it would be nice just to have via-to-copper clearance apply to vias, and drill-to-copper clearance apply to all other drilled holes. And to distinguish clearance for non-plated holes from plated holes, drill oversize would apply to plated holes except for vias.


      Or is there another way to do what I'm trying to do?

        • 1. Re: via-to-copper clearance overruled by drill-to-copper clearance

          If my understanding is right via in rules apply to pad not the drill. There are three pad types in the rules SMD, PAD and VIA but all drill holes are treated the same. That being said try this. Setup a split mixed layer in the stackup. Go to setup via padstack in menu. There shuld be an antipad tab, click on that. Click the circle anti pad and check "Pad size relative to drill size". Type in the 8 mils. Pretty sure this will get you what you want. I have used defined antipads to get copper into BGAs but never tried to make vias unique.


          • 2. Re: via-to-copper clearance overruled by drill-to-copper clearance

            Thanks, WIlliam, I will give that a try.


            I think you're right, it would normally be pad-to-copper clearance, but I

            should have also mentioned that the layout has enabled Remove Unused Pads

            in Tools > Options > Split/Mixed Plane.


            So for vias not connected to the plane copper, the pad-to-copper clearance

            seems to not apply on those plane layers. Instead it seems to be the

            drill-to-copper clearance that wins out if its value is larger than the

            via-to-copper clearance.


            To use your method with antipads, I think I would also have to disable Use

            Design Rules for Thermals and Antipads in Tools > Options > Split/Mixed

            Plane. Am I correct? Current practice at our outside layout house appears

            to have this setting enabled. I wonder what disabling it might do to the

            other plated holes if the outside layout house didn't define antipads for





            • 3. Re: via-to-copper clearance overruled by drill-to-copper clearance


              Forgot about that setting. Here is what I think I remember. Default aplied first. Padstack specific overrides default. Use default switch in tools ignores padstack overides with deefault settings. I think I got this right. Maybe someone else can confirm.