AnsweredAssumed Answered

Cannot connect Nets to Hierarchy block ports (solved)

Question asked by tmiddleton on Feb 13, 2019

Solution below..

Something seems to have happened to my hierarchy block and I cannot connect nets to the ports. When I drag the net to the port pin, the connection shows the asterisk like it is going to connect, then it turns to a square block. I also found that other ports that were previously connected, if I disconnect net and try to reconnect the same behavior happens. I have made certain that the grid spacing (0.1in) is set in both the library symbol editor and also in the schematic, I've tried snap to grid in the schematic.

 

While writing this up, I solved the issue, so I thought I would share anyway..

 

Solution:

What you need to make sure when this happens is that the pins are all within the outline of the symbol

CORRECT

This is the correct way to have the outline (slashed line) on/outside of the pin connection point (point of triangle)

 

INCORRECT

This is where the issue was, the connection point of the pin (point of triangle) was outside of the outline (slashed line)

Outcomes