1 Reply Latest reply on Feb 25, 2019 3:07 AM by gloustau

    modeslim 10.5c very slow when using stand alone license

    gloustau

      Hi,

       

      I have some servers at the LM_LICENSE_FILE and MGLS_LICENSE_FILE, also for continue working while I'm traveling I have a license.dat file at LM_LICENSE_FILE.

      When I'm at the office everything works perfect and fast, but when I'm not connected to my company network modelsim is very very slow.

      It takes from 1 to 5 minutes to open, also when I launch a simulation it compiles ok but when it get to:

      # [exec] elab

       

      it takes up to 5 minuts to show:

       

      # vsim -t ps -L work -L work_lib -L fifo_171 -L fifoInput -L OutputFifo -L TFCInputFifo -L altera -L lpm -L sgate -L altera_mf -L altera_lnsim -L twentynm -L twentynm_hssi -L twentynm_hip Compactor_tb

       

      and start simulating.

       

      I suspect that this has something to do with modelsim trying to reach the license servers.

      What would be the proper configuration to avoid these big delays?

       

      Thanks,

      Guillermo

        • 1. Re: modeslim 10.5c very slow when using stand alone license
          gloustau

          My current solution is delete the LM_LICENSE_FILE &  MGLS_LICENSE_FILE environment variables and to have 2 different scripts to run, on if I'm at my office connected to the company network and I can reach the license servers and one for if I'm not connected to company network that sets LM_LICENSE_FILE to my local license.dat

           

          is not the best solution but it dos the trick

           

          Guillermo