AnsweredAssumed Answered

Problem with PADS 2.4-2.6 using an NAS Drive - solved

Question asked by victor on Oct 30, 2019

I have had a regular support agreement with Mentor for ages and have slowly kept up 

by updating my installs, going back to good old 2004SP2 and well before.

 

I recently decided to jump from 2.3 to 2.6 only to discover that PADS no longer

works correctly with my NAS drive (D-Link DNS-323).  I haven't made any changes

to this configuration in years, although I did have to recently rebuild the Windows 

because of an unrecoverable boot failure.

 

I have duplicated the problem on another computer.

 

What happens is if I try to open a file on the NAS drive, I get an OLE error.

Now, I also tried 2.4 and 2.5 and they have the same problem.  This ONLY occurs on

the NAS drive.  I can look at library files and even open a library device but if I try

to close the library device I get the same OLE error.

 

Before you ask, this problem DOES NOT happen if the pcb is on a local hard drive

or a USB drive, even if the drive is set up as a mapped network drive.

 

Mentor support suggested the most OLE errors happen because of install errors but

I haven't seen that and it fails on 2.4, 2.5, and 2.6 in exactly the same way.  I have

sent some procmon dumps to support and am waiting word back, but given the way

Mentor works, if they acknowledge that the bug exists they won't fix it for 2 or 3 years, 

if ever.

 

So, have any of you seen weird NAS problems?

 

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

OK, I figured it out.

 

The D-Link DNS-323 NAS box requires SMB 1.0 to be enabled. In the the latest

update of W10-64 Pro it appears that MS sneaked in a new option:

 

 

 

Notice the "automatic removal" option. The server and client options have been in there for ages.

The automatic removal is new

 

Now, if you just blindly check the lop level SMB 1.0 box, it enables all 3 sub boxes. The automatic

removal must dynamically turn SMB 1.0 off and on, and I think that is the problem. I disabled both

server and automatic removal and now 2.5 works.  

 

 

 

 

Outcomes