AnsweredAssumed Answered

Not seeing newly created power and ground off page types.

Question asked by dave1108 on Dec 12, 2019
Latest reply on Dec 12, 2019 by benradu2
  1. Open an older schematic that has multiple power and grounds (+15V, +12V, +5V, -15V, -12V, -5V, dig gnd, gnd1, agnd, agnd2 using only two symbols (+5V, -5V) with different net names for power and ground (don’t ask me I just started here).
  2. Opened part editor and created different new power and ground symbols for the +15V, +12V, -15V, -12V… and net names.

Problem:

                When I go to add the new nets to the schematic it only cycles through the old power net selection and no new ones, just to be sure Pads wasn’t getting confused I created a new power symbol of a box with a triangle inside and saved the CAE as xxpwr, added it to the other off-page type (power) and assigned a signal name of xxpwr1.

 

Still the same problem.

If I open a new schematic and copy the old one into a new instance the new net names are there.

I’ve tried:

  •                 Exporting the old schematic and reimporting it, no fix.
  •                 Edited the asci file, adding the new xxpwr1 and importing the file, no fix.
  •                 Created a schematic with just one resistor and the power xxpwr1 and copying that to the old schematic, then adding resistor to isolate a net then adding the xxpwr1, and when I cycle through the power symbols it’s not there.

I’ve run into this problem several years ago at another company, didn’t find a solution then either.

Thanks in advance,

Dave

Outcomes