2 Replies Latest reply on Jun 9, 2009 7:11 PM by hwee-ling.goh

    LVS REPORT statement not found

    hwee-ling.goh

      The Calibre LVS stopped halfway during the verifications giving an error on LVS REPORT statement not found despite the fact that this statement is already inside the rule deck. Tried with different versions of Calibre too but of no help. It still produces the same error. Anyone has any idea?

       

      Thanks in advance!

        • 1. Re: LVS REPORT statement not found
          chris_balcom

          Hi Hwee-ling.goh,

           

          Sometimes statements appear to be in the SVRF rulefile even though they aren't actually used during the Calibre job. Searching within a text editor, or using grep in a unix shell are commonly used to check for the existence of certain statements in a rulefile but these methods can sometimes be inaccurate if the statements are within unused #IFDEF statements or c-style  /* ... */ comments.

           

          I wonder if many people would be interested in some technique that could be used to check for such things. It's easy if the c-style comments and #IFDEF statements enclose just a few lines but sometimes they span hundreds of lines. My current calibre.vim file is not sensitive to c-style comments and I don't have enough experience with vim files to know if it's possible to add this capability.

           

          If someone with .vim file experience is reading this, would you let us know if you think it might be possible to check for c-style comments?

           

          There should be alternate techniques we could use to show just the lines that are actually used from a rulefile. If anyone is interested in those let me know and I'll get more details.

          • 2. Re: LVS REPORT statement not found
            hwee-ling.goh

            Hi Chris,

             

            Thanks for your information. I found the problem that it was really the /* ... */ that was causing the problem to comment out the statement.