AnsweredAssumed Answered

Error in eldo simulation when running with premier + multi-thread

Question asked by ktlee on Jun 8, 2020

Hi,

 

I encounter the simulation error when I try to run eldo simulation with premier and multi-thread, here is how I submit the command to the server:

 

bsub  -q reg -R "rh60" -P xxxx -Ip -n 4 eldo -use_proc ALL -genieartist -noconf -outpath ../psf -gwl jwdb -stver -premier -queue -l sim -i *.cir &

 

And I got the error when it's starting the elaborating phase:

 

***> 2-Jun-2020 12:20:38 - STARTING ELABORATION PHASE ...

Note 1021067: Premier in multi-threading mode (8 processors used)

Error Code 2 .
Eldo has encountered an internal error and must close.
Please call or visit Mentor Customer Support (http://supportnet.mentor.com/) for assistance.

 

 

I notice that, I don't see such an error when I only run eldo with a single-processor using command:

bsub  -q reg -R "rh60" -P xxxx -Ip eldo -genieartist -noconf -outpath ../psf -gwl jwdb -stver -premier -queue -l sim -i *.cir &

 

Or when I run eldo with classic run with or without multi-thread (without using -premier).

 

 

I also see this problem when I run the Questa ADMS, what I get is:

# ** Error: (vasim-4223) Internal Error
# Simulation Finished.
# End time: 15:42:39 on Jun 08,2020, Elapsed time: 0:00:52
# Errors: 0, Warnings: 5
# ** Error: Loading design failed

 

Thank you in advance

Outcomes