AnsweredAssumed Answered

Hostid from ethernet instead of dongle (Linux)

Question asked by m_koziar_rdpan on Sep 4, 2020
Latest reply on Sep 24, 2020 by guy_wettstein

Hello,

I have USB Dongle that is correctly detected by our linux server and  lmutil lmhostid -flexid command. (It took an effort to do this, but it is working).

 

In our license file we have flexid, but when the lmgrd is starting it is still trying to get hostid from ethernet not from flexid.  Is there any way to force mgcld to use dongle hostid?

 

lmhostid

root@praca:/opt/mgls/mgls_v9-22_3-1-0.aol/bin# ./lmhostid
lmhostid - Copyright (c) 1989-2019 Flexera. All Rights Reserved.
The FlexNet host ID of this machine is ""001a80d3db61 001f3b28c803""
Only use ONE from the list of hostids.

 

root@praca:/opt/mgls/mgls_v9-22_3-1-0.aol/bin# ./lmhostid -flexid
lmhostid - Copyright (c) 1989-2019 Flexera. All Rights Reserved.
The FlexNet host ID of this machine is "FLEXID=9-0e2cba2b"
root@praca:/opt/mgls/mgls_v9-22_3-1-0.aol/bin#

 

log: 

 

...

11:07:03 (mgcld) (@mgcld-SLOG@) ===============================================
11:07:03 (mgcld) (@mgcld-SLOG@) === Vendor Daemon ===
11:07:03 (mgcld) (@mgcld-SLOG@) Vendor daemon: mgcld
11:07:03 (mgcld) (@mgcld-SLOG@) Start-Date: Fri Sep 04 2020 11:07:03 CEST
11:07:03 (mgcld) (@mgcld-SLOG@) PID: 5188
11:07:03 (mgcld) (@mgcld-SLOG@) VD Version: v11.16.4.0 build 252457 x64_lsb ( build 252457 (ipv6))
11:07:03 (mgcld) (@mgcld-SLOG@)
11:07:03 (mgcld) (@mgcld-SLOG@) === Startup/Restart Info ===
11:07:03 (mgcld) (@mgcld-SLOG@) Options file used: None
11:07:03 (mgcld) (@mgcld-SLOG@) Is vendor daemon a CVD: No
11:07:03 (mgcld) (@mgcld-SLOG@) Is FlexNet Licensing Service installed and compatible: No
11:07:03 (mgcld) (@mgcld-SLOG@) FlexNet Licensing Service Version: -NA-
11:07:03 (mgcld) (@mgcld-SLOG@) Is TS accessed: No
11:07:03 (mgcld) (@mgcld-SLOG@) TS access time: -NA-
11:07:03 (mgcld) (@mgcld-SLOG@) Number of VD restarts since LS startup: 0
11:07:03 (mgcld) (@mgcld-SLOG@)
11:07:03 (mgcld) (@mgcld-SLOG@) === Network Info ===
11:07:03 (mgcld) (@mgcld-SLOG@) Listening port: 35065
11:07:03 (mgcld) (@mgcld-SLOG@) Daemon select timeout (in seconds): 1
11:07:03 (mgcld) (@mgcld-SLOG@)
11:07:03 (mgcld) (@mgcld-SLOG@) === Host Info ===
11:07:03 (mgcld) (@mgcld-SLOG@) Host used in license file: praca
11:07:03 (mgcld) (@mgcld-SLOG@) HostID node-locked in license file: FLEXID=9-0e2cba2b
11:07:03 (mgcld) (@mgcld-SLOG@) HostID of the License Server: "001a80d3db61 001f3b28c803"
11:07:03 (mgcld) (@mgcld-SLOG@) Running on Hypervisor: Not determined - treat as Physical
11:07:03 (mgcld) (@mgcld-SLOG@) ===============================================
11:07:03 (mgcld) No valid hostids, exiting
11:07:03 (mgcld) EXITING DUE TO SIGNAL 34 Exit reason 2
11:07:03 (lmgrd) mgcld exited with status 34 (Invalid host)
11:07:03 (lmgrd) Please correct problem and restart daemons

 

 

Thank you for any help

Outcomes