1 Reply Latest reply on Feb 16, 2010 6:15 AM by olivier_arnaud

    pullups and open-collectors

    volain

      I'm having trouble with the DRC for OCL pins.  I get the following error messages for the same net which has an OCL pin at one end, an INPUT pin at the other, and a resistor(R52) to my +2_5VD power:

      1)     "More than one driver on a net"

      2)     "Open Collector pin is not tied to VDD"

       

      I tried adding R52 to the "pull-up symbols" and +2_5VD to "pull-up nets".  Didn't work.  Also Tried adding RES (DEVICE value) to pull-up symbols.  I'm not sure how to define pullup symbols and pullup nets correctly.

       

      What am I doing wrong?

       

      Thanks,

       

      Barry

        • 1. Re: pullups and open-collectors
          olivier_arnaud

          Hi Barry,

           

          The first erroneous error message "More than one driver on a net" comes from drc-106 which indeed does not work as expected. This is a known issue which has already been reported and will be fixed. For the time being, simply turn this check off to avoid getting these messages.

          The second check (drc-201) about open collectors seems to work fine but you've well spotted the fact that the setting is important.

          First of all you indeed need to enter in the Pull-up Net(s) Values column which symbol is used. The correct syntax is <partition_name>:<Symbol Name>. So if you look at the Properties window when the pull-up symbol is selected in a schematic, you can find this information in the "Partition" and "Symbol Name" rows. For example:  Resistor:resi.1

          Watch out the case as Resistor:resi.1 may work when Resistor:RESI.1 would not!

          Multiple values can be entered if necessary.

          Regarding the Pull-up net(s), the Values column must contain the name of the net connected to the power tap through the resistor. This net gets its name from the power tap Global Signal Name property value. In my case, I use a generic power tap VCC which I adapt to my needs by entering a different Global Signal Name value like +5V or +3.3V ... This is this value that I use in the Pull-up net(s) Values column.

          If you follow these instructions, it should work.

           

          Please let me know if you can't fix the problem.

           

          Cheers

          Olivier