3 Replies Latest reply on Feb 25, 2010 6:18 AM by ted_casper

    pass trace width from DxDesigner to PADS

    greg.deakins

      Trying to setup passing trace width info from DxDesigner to PADS. Not sure of all the setups needed in cfg file to get this working. Any thoughts/pointers?

        • 1. Re: pass trace width from DxDesigner to PADS
          ted_casper

          I believe you will need to pass design rules during forward annotation for this to work.  The CNS (contraints) file will contain any classes you create based on design rules.  If you have multiple nets that share the same rules, create a class and assign it to the desired nets.  The remaining nets will default to the "Default" rules. 

           

          Be careful as conditional rules cannot be backward annotated to DxDesgner nor can they be created in DxDesigner.  It appears PADS9x fixed the problem with conditional rules blowing up DxDesigner's CNS file during back annotation.   If you PADS design does not contain conditional rules you will be fine.   We find it easiest to only forward annotate rules.

           

          One more thing,  if you are using METRIC units, there are some more hoops to jump thru.  Make sure you have an unattached UNIT=METRIC property on the first page and check your .eco forward annotation file (pause before updating PCB Design) is checked during forward annotation.  The first line should read: *PADS-ECO-V9.1-METRIC*

          1 of 1 people found this helpful
          • 2. Re: pass trace width from DxDesigner to PADS
            Ompz

            Hello, I have the same problem. In DxDesigner-Setup-Settings-Schematic editor I choose "Mimimeters" like unit and in Constraint Window I write all values in milimeters but when I do Forward to Pcb from Layout, first line in ECO file is *PADS-ECO-V9.1-MILS* and all values are changed to mils. Why? Is is necessary to change units in another place in DxDesigner?

            • 3. Re: pass trace width from DxDesigner to PADS
              ted_casper

              To get DxDesigner to netlist in METRIC you must add the unattached property UNIT=METRIC

               

              First your .PRP (property) file must contain the name UNIT or you will not be able to add it to the schematic.

               

              Also, your CNS file should be converted to metric.  Attached is a PADS90.CNS file converted to Metric.  You will need to change its values to meet your needs.  NOTE: once you go metric, you will need to manually check each new release of the CNS file for new entries and modify your metric version to accommodate the new features.

               

              To add the UNIT=METRIC property to the schematic, click on an open area of PAGE 1 then right click and select properties.  In the first open row, click and select UNIT from the drop down list then type in the value METRIC.  I suggest making the value visible.  It will appear in the lower right corner of you schematic.  You can drag it to whatever location you like.  The net lister will now create the header in METRIC.

               

              Metric.JPG

               

              Please note that the design rules still show up in the comparison file in English units.  This is a pain and I consider it a major bug in MENTOR's handling of optional units.  However, your design rules will pass correctly in metric as long as the header in the ECO file reads METRIC.

               

              CAUTION:  As you get used to using design rules in metric, I suggest you always create backups of your PCB and schematics before an ECO process is done.  Once you understand how things work, you will find the backup may not be necessary.

               

              Back annotation of constraints in metric is a very complex operation and be aware it will not work using the DxDesigner Link in PADS.