3 Replies Latest reply on Jul 1, 2010 4:37 AM by strangd

    Library Manager Update process crash

    MaBUa

      Hello all,

      I try to describe here some of my problem with Library Manager... It is strange and finish by crash.

       

      I have a central library created in EE2007.5 (Dxd) and need to update into EE2007.9 (I have GBS Id 13996)

      I open lmc file in a Library Manager 2007.9 and it starts to re-populate....

      - it starts by parts .. it is ok

      - then goes through symbol and there it crashed.

       

      Before this the converter (updater..?? don't know how to call it) tells me that I have one symbol used in 2 parts (it was true) and that I mapped it in each part differently.. it was not true.

      So I decided to delete this symbol and part.. that I create it after update manually again.

       

      So, now I'm not able to finish the update process -> can't use it in a new version EE2007.9 (solve it Id 14357 ??)

       

      Can somebody help me?

       

      Many thanks in advance

       

      BR

      Martin

        • 1. Re: Library Manager Update process crash
          strangd

          Good day Martin:

           

          Sad to say but this will happen in earlier versions of Library Manager too.  You may need to delete all the places that this duplicate symbol/part exists.  If you delete only one of the two occurrences and the .lmc file may index, but you may well find that the next time that you need to index the .lmc file the software will error with the same, now phantom, symbol/part.  Do an ASCII export of the good symbol/part before you delete it for the libraries.  Perform your migration to EE7.9.

           

          I have had these phantom part memories in the .lmc file to the point where I had to make a new partition and move all of the parts from the old partition into the new partition.  The old partition would not delete even after I deleted all of the parts out of it because it did not believe itself to be empty.  The resultant library ported into EE7.9 but I have not done a lot of testing by Packaging any designs.

           

          Good luck

          Dwain

          • 2. Re: Library Manager Update process crash
            MaBUa

            Good day Dwain,

            thank you for your email.

             

            I played with it for a long time and I solved it.

            I used the script LIBRARYCHECKER  and found out which parts are duplicated. There were some.

            But after that the library updater crashed during loading data again.

            What was strange that I deleted the symbol in library manager and it doesn't deleted the file from my HDD. After manual deleting it worked.

             

            Concerning the ASCII import of symbol... it was easy to export ASCII file from library manager (library service tool) in DC flow but in Dx flow it is not allowed... only to take a symbol file with the extension "1"

            and import into the particular symbol partition.

             

            So, I'm glad to be successful

            Martin

            • 3. Re: Library Manager Update process crash
              strangd

              Yes, the when you open a symbol in Wordpad you see that the format is already in ASCII.  You don't have to export symbols into an ASCII formatted file. I should have said to to copy the symbols over to a safe, temporary directory instead of making a generalized export statement.

               

              Good luck

              Dwain