5 Replies Latest reply on Jan 12, 2011 12:04 AM by ph3

    boardstation XE installation problems

    ph3


      I'm a fairly novice *nix user and am trying to use Boardstation for the
      first time.

       

      I have a fresh install of RHEL Client 5.3.
      Fresh install of Boardstation 2007.

       

      I think that I've followed most of the install documentation, I've set
      various environment variables and board architect and design architect
      appear to be starting up OK until i get 2 font warnings, followed by
      errors and shown below.

       

      //
      // WARNING:    Font loading failed. Please see the following notes for
      more information.
      // NOTE:       Xhost            = 'olivaw.ecs.soton.ac.uk',
      // NOTE:       Xserver          = 'olivaw.ecs.soton.ac.uk',
      // NOTE:       font name        = '-*-times-medium-r-*-120-*',
      // NOTE:       font package     = '(null)',
      // NOTE:       source font path = (null).
      //
      // WARNING:    Font loading failed. Please see the following notes for
      more information.
      // NOTE:       Xhost            = 'olivaw.ecs.soton.ac.uk',
      // NOTE:       Xserver          = 'olivaw.ecs.soton.ac.uk',
      // NOTE:       font name        = 'da_tool.icons',
      // NOTE:       font package     = 'mgc_home.ixl',

      // NOTE:       source font path =
      /usr/bin/BSXE/2007.7BSXE/MGC_HOME.ixl/registry/fonts/.
      // Fonts are configured incorrectly
      // Cannot initialize device driver.
      // ERROR -- Unhandled exception caught:
      Invalid font requested
      // Error: call stack traceback not available on this platform.
      // Traceback end

       


      The manuals troubleshooting section has something on da_tools.icons,
      which if i run their command i get this.

       

      $ xfd -fn da_tool.icons
      Warning: Cannot convert string "da_tool.icons" to type FontStruct
      xfd:  no font to display

       

      of the three solutions;
      'xset q' shows a sensible font path including
      BSXE/MGC_HOME.ixl/registry/fonts

       

      I've tried to create a font directory using mkfontdir to no avail
      (including reboots and xset -fp rehash)

       

      i don't understand how to copy and convert fonts (copy from where?  how
      do i convert them?)

       

      Any help gratefully received.

        • 1. Re: boardstation XE installation problems
          sdd_tina

          In $HOME/mgc directory there should be an install.ixl directory and inside there should be a directory called LOGS.

          You want to look at the latest mip_history.txt file to see if there are any post-install or errors that indicate that the installation did not finish properly.

          Look specifically to the fonts that you are reporting.

           

          Our Customer Support team (environment team) should be able to further assist.  Good luck and thanks for the posting.

          • 2. Re: boardstation XE installation problems
            ph3

            Dear tina,

             

            Thanks for your response.  Finding the logs is helpful I'd looked in dmesg and var/log for info to no avail (not quite sure why i didn't look in HOME).

             

            They don't specifically mention the fonts reported, there is a problem with some of the others (excert below).  This is right at the end of the log file, although the installation tool reports a complete install (and verifying the install imediately afterwards is OK too) i don't know whether this script is the last one to run or whether these errors prevent other scripts running.

             

            Any further information would be gratefully recieved.

             

            Thanks again.

            P

             

            Running Script:( Post Install )
                /usr/bin/BSXE/2007.7BSXE/MGC_HOME.ixl/pkgs/base.ixl/base_post_install_script
            -target /usr/bin/BSXE/2007.7BSXE -msicmd /root/mgc/install.ixl/bin/msi_cmd -mgc
            home /usr/bin/BSXE/2007.7BSXE/MGC_HOME.ixl -vco ixl
            ENV Variables
            MG_INSTALL_MODE=interactive
            MG_INSTALL_SOURCE=/root/BSXE/BSXE2007
               **** BEGIN SCRIPT TRANSCRIPT ****

             

            Couldn't determine full name for stroke-iso88591-p.gsr
            Couldn't determine slant for stroke-iso88591-p.gsr
            Couldn't determine weight for stroke-iso88591-p.gsr
            Couldn't get family name for stroke-iso88591-p.gsr
            Couldn't determine full name for mgc-v1-stroke-ascii.gsr
            Couldn't determine slant for mgc-v1-stroke-ascii.gsr
            Couldn't determine weight for mgc-v1-stroke-ascii.gsr
            Couldn't get family name for mgc-v1-stroke-ascii.gsr
            Couldn't determine full name for stroke-iso88591-m.gsr
            Couldn't determine slant for stroke-iso88591-m.gsr
            Couldn't determine weight for stroke-iso88591-m.gsr
            Couldn't get family name for stroke-iso88591-m.gsr
            Couldn't determine full name for stroke-ascii.gsr
            Couldn't determine slant for stroke-ascii.gsr
            Couldn't determine weight for stroke-ascii.gsr
            Couldn't get family name for stroke-ascii.gsr

             

               **** END SCRIPT TRANSCRIPT ****
              

            • 3. Re: boardstation XE installation problems
              sdd_tina

              Hello again -

               

              The fact that you have entries in the log seems enough to me to have this looked at by Customer Support.  It may be that somehow you are crossed over two different machines (RHEL3 vs RHEL4 as an example).  Because there are a number of questions that would need to be asked, I would log an SR with Customer Support (SupportNet) and have our Environment Support team take it from here.  Give a shout back once you've connected with them.  Thanks for the feedback today!

              • 4. Re: boardstation XE installation problems
                Ramp

                Did you get any assistance on this issue regarding the messages? I am getting something similar.


                Thanks,

                • 5. Re: boardstation XE installation problems
                  ph3

                  Sorry i should have posted a resolution at the time.

                   

                  I did resolve it, it was purely font settings.  I can't quite remember the precise order of things but in general mkfontdir and xset seemed to solve this particular problem.

                   

                  Generally find the directory with the missing fonts, run mkfontdir in that directory and add it to the path in xset, (read the man page the syntax is somewhat unusual).

                   

                  Hope this helps.

                  P