1 Reply Latest reply on Jan 10, 2011 9:41 AM by weston_beal

    DDR3 wizard- missing receiver voltage threshold

    Katkoria.Deepak

      Hello Expert,

      For DDR3 wizard simulation, I am considering ac/dc threshold for measurment.

       

      1). For receiving model,

      I am getting following message "

               IBIS Model: S15RXRT120

               Model does not have a [Receiver Thresholds] section.

               Missing Vinh and Vinl thresholds in the [Model Spec] section.

               Only Vinh and Vinl thresholds are specified in the [Model] section, and will be used for both AC and DC thresholds.

               Net: /DDR-DQ13

                 "

      receiving controller model(IBIS file)

      "[Model]       S15RXRT120
      Model_type       Input
      Polarity         Non-Inverting
      Vinh  =   1.0V
      Vinl  =   0.5V"

       

      DO you want me to add the AC/DC threshold from Jedec standard into IBIS file?

      How can I remove this error ?

       

      2). second error I am getting is for data signal :

      "These nets have inappropriate IBIS model types attached, for the selected simulations:

         Net: /DDR-AA8  (Address/Command Net)

            Controller pin: 7S00.AD28  (DDR_DA_8)  --Model is input only, but needs to be output or I/O

      Model: S15RXRT120

      "

      In wizard, I have setup controller data line like:

      S15RXRT120   

      i/p, DDR3, 1.5V RX, 120 Ohm ODT

      DQ, DM

      Read

      S15TX    

      o/p, DDR3, 1.5V TX, single

      DQ, DM

      Write

       

      Could you please suggest the solution for above problem ..

       

      Thanks,

      Deepak

        • 1. Re: DDR3 wizard- missing receiver voltage threshold
          weston_beal

          The AC and DC thresholds should be defined in the [Receiver Thresholds] block of the IBIS model. See the IBIS 4.2 specification for details about that.

           

          The second error is telling you that the model you have assigned to the controller pin on the address net is an input type. This model cannot drive the signal from the controller. Your IBIS model is not correct, or you have interactively assigned the wrong model to this pin. The log file tells you where to look to find the problem. The pin 7S00.AD28 has the wrong model. Select the net DDR-AA8 and observe the models assigned to the pins on that net. In the model assignment window you should see green triangles with little letter R next to each pin name. If there is a red ? then the model is not assigned. If the green triangle does not have a R by it then the model is assigned interactively and you should remove the model assignment.