8 Replies Latest reply on Apr 1, 2012 1:30 PM by samuel.kvasnica

    Running DxDesigner under Ubuntu 10.10

    artsiom.shchatsko

      Has anyone tried running DxDesigner under Ubuntu 10.10?

      There seems to be a problem with MainWin not willing to work when hostname is not mapped to 127.0.0.1.

      In Ubuntu 10.10 network-manager maps hostame to the real IP addrecc, not to the loopback address.

       

      This is what I get in mwrpcss_event.log:

       

      RPCSS ServiceMain failed with 1702 (000006a6)
      The binding handle is invalid.

       

      Here is what I get on stdout:

       

      /$ $SDD_HOME/common/linux/bin/viewdraw 2>&1

      Creating Registry Directory /home/cioma/.mgc/7.9EE/mw/5.2/linux
      Creating /home/cioma/.mgc/7.9EE/config.ini
      Creating User File /home/cioma/.mgc/7.9EE/env.sh
      Creating Registry for Product Family: common
      regedit /opt/design/hw/mentor/7.9EE/SDD_HOME/common/linux/epd.reg
      ERROR-REGISTER FAILED - /opt/design/hw/mentor/7.9EE/SDD_HOME/common/linux/epd.reg
      regedit /opt/design/hw/mentor/7.9EE/SDD_HOME/common/linux/epd_unix.reg
      ERROR-REGISTER FAILED - /opt/design/hw/mentor/7.9EE/SDD_HOME/common/linux/epd_unix.reg
      register /opt/design/hw/mentor/7.9EE/SDD_HOME/wv/linux/bin/dash /Register
      Registering /opt/design/hw/mentor/7.9EE/SDD_HOME/common/linux/lib/libOutputWindow70.so
      ERROR-REGISTER FAILED - /opt/design/hw/mentor/7.9EE/SDD_HOME/common/linux/lib/libOutputWindow70.so
      Registering /opt/design/hw/mentor/7.9EE/SDD_HOME/common/linux/lib/libTestPointAddin.so
      ERROR-REGISTER FAILED - /opt/design/hw/mentor/7.9EE/SDD_HOME/common/linux/lib/libTestPointAddin.so
      Registering /opt/design/hw/mentor/7.9EE/SDD_HOME/common/linux/lib/libHelpNav.so
      ERROR-REGISTER FAILED - /opt/design/hw/mentor/7.9EE/SDD_HOME/common/linux/lib/libHelpNav.so
      Registering /opt/design/hw/mentor/7.9EE/SDD_HOME/common/linux/lib/SymbolWizard.ocx
      ERROR-REGISTER FAILED - /opt/design/hw/mentor/7.9EE/SDD_HOME/common/linux/lib/SymbolWizard.ocx
      Registering /opt/design/hw/mentor/7.9EE/SDD_HOME/common/linux/lib/presym70.ocx
      ERROR-REGISTER FAILED - /opt/design/hw/mentor/7.9EE/SDD_HOME/common/linux/lib/presym70.ocx
      Registering /opt/design/hw/mentor/7.9EE/SDD_HOME/common/linux/lib/libCommandBarSvr70.so
      ERROR-REGISTER FAILED - /opt/design/hw/mentor/7.9EE/SDD_HOME/common/linux/lib/libCommandBarSvr70.so
      register /opt/design/hw/mentor/7.9EE/SDD_HOME/wv/linux/bin/SymbolWizardAuto /REGISTER

      ...............

       

      If I just disconnect Ethernet cable and restart the PC the hostname is mapped to 127.0.0.1 in /etc/hosts and DxDesigner starts OK.

        • 1. Re: Running DxDesigner under Ubuntu 10.10
          robert_davies

          Ubuntu is not a supported OS, we support Suse and Red Hat Linux only.

          • 2. Re: Running DxDesigner under Ubuntu 10.10
            artsiom.shchatsko

            Yes, yes, I know. The question was if anyone tried it, not if Ubuntu is supported

            • 3. Re: Running DxDesigner under Ubuntu 10.10
              taco.de.vries
              Artsiom,

               

              I ran into the same problem at about the same time :-)

              I bought a new laptop and decided to try ubuntu this time iso debian.

               

              After some digging, I found that the problem is caused by NetworkManager.

              This app sets up network for wired and wireless network. There seems to

              be a bug in it, it rewrites /etc/hosts every time you get a network change.

              The rewrite is not the problem, but it allways adds a line for IPV6.

               

              This is a line that looks like this:

               

              ::1 <your hostname> localhost6.localdomain6 localhost6

               

              If you comment out that line, the tools will start.

               

              Version 0.8.3 of NetworkManager seems to fix this, but for some reason I cannot

              update to that.

               

              Taco

               

              PS. I am aware that Ubuntu is not supported..

              • 4. Re: Running DxDesigner under Ubuntu 10.10
                artsiom.shchatsko

                Many thanks Taco for a kick in a right direction! I know you dig deep

                 

                Indeed updating to network-manager v0.8.3 seems to fix the issue. Now my /etc/hosts is back to normal:

                /$ cat /etc/hosts
                127.0.0.1    computer    localhost.localdomain    localhost
                ::1    computer    localhost6.localdomain6    localhost6


                # The following lines are desirable for IPv6 capable hosts
                ::1     ip6-localhost ip6-loopback
                fe00::0 ip6-localnet
                ff00::0 ip6-mcastprefix
                ff02::1 ip6-allnodes
                ff02::2 ip6-allrouters
                ff02::3 ip6-allhosts

                 

                Here is what I did. This ppa https://launchpad.net/~network-manager/+archive/trunk provides the latest network-manager related packages.

                But currently network-manager package for Maverick fails to get built there because of missing isc-dhcp-client dependency. I think they will resolve it very soon but I couldn't wait

                So I modified the aforementioned ppa link to have it point to the Natty release (deb http://ppa.launchpad.net/network-manager/trunk/ubuntu natty main).

                Then it complained about some dependencies and these two ppas covered them:

                https://launchpad.net/~ubuntu-mozilla-security/+archive/ppa

                https://launchpad.net/~kubuntu-ppa/+archive/beta

                 

                Voila! Now I have network-manager v0.8.3 installed and it doesn't mess up /etc/hosts anymore. DxDesigner and Expedition start just fine.

                 

                Now I think I'll open another topici about enabling OpenGL in Expedition under Ubuntu 10.10 x64

                • 5. Re: Running DxDesigner under Ubuntu 10.10
                  artsiom.shchatsko

                  Let's resurrect the topic: does anyone run EE7.9.2 under Ubuntu 11.04 Natty?

                  On my machine it takes a very long time to start any of the tools. It looks it goes faster if I constantly switch focus from terminal where I started DxDesigner to another window and back.

                   

                  strace on viewdraw start gives a lot of futex timeout errors.

                   

                  I tried EE7.9.2 under Ubuntu 10.04.2 (both 32- and 64-bit) and EE tools start fast there.

                  • 6. Re: Running DxDesigner under Ubuntu 10.10
                    baratli.karim

                    Hi,

                     

                    I'm trying to install EE7.9.2 on Ubuntu but i can't lunch install.ixl. Can you help me plz?

                    Thank you in advance.

                     

                    Karim Baratli

                    • 7. Re: Running DxDesigner under Ubuntu 10.10
                      artem.kravchenko

                      Looks like some problem with MainWin on Linux.

                      • 8. Re: Running DxDesigner under Ubuntu 10.10
                        samuel.kvasnica

                        Well, yes, most such troubles are about MainWin. Not sure what historical reasons lets them use it and why it was not ported

                        to something like Qt - like other vendors do.

                         

                        Anyway, these are 3 most common problems with Expedition/DxD:

                         

                        1. wrong host ip /etc/hosts. For some reason MainWin gets crazy if hostname does not point to local loopback.

                        This causes usually segfaults in that funny registration procedure.

                        however, pointing hostname to 127.0.0.1 is a bad idea as that is the localhost. Instead point hostname to 127.0.0.2

                         

                        2. location of tmp directory. For some reason, if system is configured for private temp-dir below user $HOME, it does not play

                        well with Mentor/Mainwin. Make sure you have common tmp in /tmp

                         

                        3. yeah, X11 libs too new. Typically startup script just hangs in each registration step.

                        Those "experts" at Mentor always link the stuff against ancient SLES x11 libs. Take older

                        libs from older distro and use "export LD_LIBRARY_PATH=/your/path/to/oldx11libs:${LD_LIBRARY_PATH}"

                        in your start script and you have good chances to run is under your latest distro version. Often just an old libx11.so.6.2.0 will do.

                         

                        In some cases, setting "export MWWM=allwm" helps to play more nicely with the windows manager

                         

                        Mostly you will get it work, but generally MainWin on linux is nothing but a bad joke. Not speaking about printing,

                        filesystems with 64bit inodes, etc...