5 Replies Latest reply on Apr 1, 2011 12:32 AM by Joel_Pointon

    Wire colours in design

    philip

      Image1.jpg

      I am trying to use coloured wires in design. I can set the colour as above, save and close.

       

      When I open the configuration again, the wire colours have disappeared. How does this happen?

        • 1. Re: Wire colours in design
          Joel_Pointon

          Hi,

           

          This could happen if VeSys is unable to write to the configuration files.  I would check that you have permission to write to those files or that they haven't been set to 'Read Only'.

          • 2. Re: Wire colours in design
            philip

            Joel,

            I can change the drawing colours. I changed the wires default colour and the simulation default colour and these have stayed changed.

            • 3. Re: Wire colours in design
              Joel_Pointon

              That is strange that you are able to edit some of the fields because all the data is stored in the same file.  Although its unorthodox you could manually edit the colors in the VeSysDesign.ini file which is located in your configuration folder, if you are not comfortable doing this you could e-mail it to me and I'll update it for you.  If you would like me to do this I would need a copy of your ini file along with the list of the Colors required and their RGB values i.e. B = 0,0,0

              • 4. Re: Wire colours in design
                philip

                Thanks for that tip, it worked and I now have my colours back. I looked in "VeSysDesign_Template.ini" and copied the structure and colours.

                 

                I then tried to add a new colour in the configuration editor, saved, exited and went back in. The new colour had saved ok.

                • 5. Re: Wire colours in design
                  Joel_Pointon

                  I'm not sure why manually adding them fix it, maybe if you save the configuration with 0 or mininal colors it causes a problem.

                   

                  Anyway the important thing is that your issue is resolved.