3 Replies Latest reply on Jul 22, 2011 4:33 PM by huschle

    "Error 5709 - Could not open schematic" and other problems...

    huschle

      Hi,

       

      I'm new to DxDesigner and currently working on a project with an FPGA-design. The project was created in PADS 9.2, but meanwhile I'm running PADS 9.3.1. I tried to pass the design on to PADS Layout (which worked fine in PADS 9.2 when it was only a few sheets), but now I get the following error:


      Note 5996: Using Config  File  C:\MentorGraphics\9.3.1PADS\SDD_HOME\standard\pads93.cfg

      Warning 5720: Check  MySchematic.err for VIEWBASE messages
      Error 5709: Could not open  schematic MySchematic
      Note 5626: Summary of Log  Files/pcb.err
      Status 0, Notes 1,  Warnings 1
      Errors 1, Failures 0, Fatals 0,  Internals 0
      PCB Forward Interface - V6.1;  DxDesigner EE7.9.2 (456558)
      c Copyright  2011 Mentor Graphics Corporation. All Rights Reserved.

      PCBFWD netlisting is  completed with errors. Check pcb.err file for notes and information.

       

       

      So the question now is: how do i fix that? The help is not any help at all (I cannot find a viewplac.ini file and I couldn't figure out how to create a board file using "-CreatePlacementData" in the command line).

       

      On a different note: How can I fix "drc-120 -... Range mismatch across component" errors?

       

      I'd appreciate any help! Thanks.

        • 1. Re: "Error 5709 - Could not open schematic" and other problems...
          patricia.charity

          I have an answer on the DRC-120 error. I cleared mine by deleting 1 or more of the connections and then rehooking them back up. Seems to have been an issue with the net names that were attached to the component.

          Hope that helps you.

          1 of 1 people found this helpful
          • 2. Re: "Error 5709 - Could not open schematic" and other problems...
            huschle

            Thanks for the hint. In a first test deleting some of the nets and creating new ones resolved the drc-120 error (after I named the new nets again).

             

            About the Error 5709: I think I figured it out. Apparently DxDesigner doesn't like it if you delete the default "symbol library" reference (the one with the projects name that refers to the project folder with a dot) in the project settings. After I recreated that setting, the viewbase error was gone and only "real" PCB errors showed up - hooray.

             

            Edit 1: FYI: About the drc-120 error : apparently DxDesigner has issues handling several net name patterns that alternate between letters and numbers. This will result in the range errors, which is completly confusing... But I tested it out, for example a net name "Buffered_ADC_2_1V9" will result in an range error, whereas "Buffered_ADC_2_1V9x" won't... I think it has something to do with the net name ending with a number, even though that does not always result in that error....

            • 3. Re: "Error 5709 - Could not open schematic" and other problems...
              huschle

              Error 5709: Don't delete standard symbol library reference (project name with reference to the project directory) from project settings.

               

              drc-120: Try different net names that don't end in numbers!