9 Replies Latest reply on Feb 8, 2012 1:05 AM by thomas.scharf

    Multicore cable part number not shown in VeSys Schematic or wiring lists?

    thomas.scharf

      I have created a multicore wire (screened twisted pair) in Component Maintenance as shown here:

      MC-base.png

      MC-multicore.png

      The structure is shown under the Multicore Wires tab.

      With some difficulty I have drawn the screen twisted pair in the schematic:

      MC-design.png

      Note the terminal ring attempt. (it's a bit small!)

       

      When I look at the properties for each wire element I get the properties for that element ie, red/blue wire but no associated top level part number.

       

      MC-DWL.png

      This is a composite view of the Design Wire List. The components that make up the cable are distributed around the wire list in alphanumeric order. Note that for the two inner cores and the screen, Wire Partnumber is blank. Also having created Multicore Name for the shield as MC1, the names for the two cores are MC1a because VeSys wouldn't allow the same label. I've clearly done something wrong or out of order. We would like all the elements of a multicore (screen and cores) to appear together in the wire list and we would also like the associated top level part number for the screened twisted pair to be shown in the table.

      Please help me to achieve this.

        • 1. Re: Multicore cable part number not shown in VeSys Schematic or wiring lists?
          thomas.scharf

          My screenshots have come out so small I guess this is of no use to anyone else? Is there any way of scaling screenshots in the original post?

          • 2. Re: Multicore cable part number not shown in VeSys Schematic or wiring lists?
            Phil_Davies

            Tom,

             

            The screenshots are fine if you select them they expand

             

            Well take a look at this and come back to you shortly.

             

            Regards

             

            Phil D

            • 3. Re: Multicore cable part number not shown in VeSys Schematic or wiring lists?
              Phil_Davies

              Tom,

               

              You are  running the standard wire list in VeSys 2.0 Design which does not include “Multicore PartNumber”.

               

              You have several options.

               

              1- 1) There is a standard table for VeSys 2.0 Design that can print, on the diagram, the MC P/N.

              mc1.png

              2-   2)  You can configure the “Configured Wire List”, and include the MC P/N (C:\MentorGraphics\VeSys\reporter\templates\embedded\vesysconfig.xml) , sample attached.

               

              mc2.pngmc3.png

                    3) Finally, you can write a custom report that gives you exactly what you need

               

              R    Regards

                  

                     Phil D

              1 of 1 people found this helpful
              • 4. Re: Multicore cable part number not shown in VeSys Schematic or wiring lists?
                thomas.scharf

                Thanks Phil.

                That works. The screen (which carries the part number) still appears in a different place to the cores. We can get over that by labelling the screen differently.

                 

                I've actually found that the design wire list is more useful but there isn't an accessible xml for that one or the other reports. Would it be possible to get xml files for the other reports so that I can adjust them to meet our needs?

                I believe there's a way to get new reports to appear in the reports menu. Please remind me where to look for that.

                 

                Regards: Tom

                • 5. Re: Multicore cable part number not shown in VeSys Schematic or wiring lists?
                  Phil_Davies

                  Tom,

                   

                  Nuri wrote a great How To Document on report creation which you can find at http://communities.mentor.com/docs/DOC-2012, I would advise you to take a look and come back with any questions.

                   

                  Regards

                   

                  Phil

                  • 6. Re: Multicore cable part number not shown in VeSys Schematic or wiring lists?
                    thomas.scharf

                    Hi Phil,

                     

                    Unfortunately I'm not allowed the time on our project to learn how to use netbeans etc. I'm just hoping for something I can adjust quickly with wordpad or similar. My initial euphoria at being able to display multicore part numbers in the configured wire list (an enhancement in the 2011 version of VeSys) has been tempered by the fact that this is the only part number which can be displayed in the Configured Wire List!

                    This would have made more sense as an enhancement to the Design Wire List, but then we don't have easy .xml access that one. (Why not?)

                     

                    I changed vesysconfig.xml to see if I could get the CWL to display other part numbers, but not before I'd backed up the original vesysconfig file. VeSys refused to run my new vesysconfig report, even though I stopped and restarted it. At one stage Configured Wire List disappeared from the list of reports. Now I have reinstated the original vesysconfig.xml and it refuses to see this. I copied the VeSys 2010.2 vesysconfig.xml  into templates\embedded and this works.

                     

                    What are the conditions for VeSys to recognise vesysconfig.xml as a valid file that it can use and when does it pick it up? Does VeSys need to be restarted to pick up the latest version? Do I need to do a Refresh All? Does VeSys pick it up on entry into Reports? Why is it refusing to recognise a file which I simply renamed and reverted back to vesysconfig.xml?

                     

                    Regards: Tom

                    • 8. Re: Multicore cable part number not shown in VeSys Schematic or wiring lists?
                      Phil_Davies

                      Tom,

                       

                      The Configurable Wire List report can be extended to show;

                       

                      • Multicore PartNumber
                      • Wire PartNumber
                      • Device 1 PartNumber
                      • Connector 1 PartNumber
                      • Device 2 PartNumber
                      • Connector 2 PartNumber

                       

                      To enable these columns they need to be added into the Wire List configuration, once you have done that just close any open report and re-run (no need to close and restart the VeSys 2.0 application).

                       

                      Attached is a example report (XML) that contains the above attributes, of course if you wanted to include further attributes (or properties then you could follow the instructions at the top of the file).

                       

                      Regards

                       

                      Phil

                      • 9. Re: Multicore cable part number not shown in VeSys Schematic or wiring lists?
                        thomas.scharf

                        Hi Phil,

                         

                        Thank you for that. When I initially tried to run it in VeSys 2011, it didn't appear in the list of reports and this is the problem I've had before. When I looked at the xml using Internet Explorer it bombed out with an invalid character message:

                         

                        An invalid character was found in text content. Error processing resource 'file:///C:/MentorGraphics/VeSys2011/reporter/tem...

                         

                        <!-- Apart From attributes in IXWire section of 
                        

                         

                        Looking at the file in Wordpad:

                        <!-- Apart From attributes in IXWire section of "%VESYS_HOME%\doc\plugin\chsapi\AttributeList.html" file

                         

                        - the double quotes are different to those used elsewhere in the file. I replaced them and it now works. The whole xml file can now be viewed in IE. This may be coincidence because versions of vesysconfig have worked with these strange quotes. (No, seems to work intermittently in VeSys and IE.)

                         

                        Further testing and it all works! I changed the title to "Configured Wire List with Part Numbers" and this comes up in the VeSys Reports list. Hoorrayy!

                        Those quotes need to be fixed in your next issue of vesysconfig.xml.

                         

                        Regards: Tom