5 Replies Latest reply on Jul 9, 2012 7:09 AM by DenisL

    Layout spacing error: can't change rule?

    dmeeks

      I have my rules set for 6 mils anything-to-anything.

      When I run a spacing verification, I get a lot of errors that say pad-to-pad and pad-to-via is <10 mils. I can't find anywhere in the rules where this 10 mil limit is showing.

      Where does this 10 mil rule come from?

      Here is the text from one of the errors:

      (804.45,1718.78 L1) Distance between pads too small: U701.1,U701.2 distance is 7.09, should be >=10

       

      Thanks in advance!

      Dan

        • 1. Re: Layout spacing error: can't change rule?
          yan_killy

          Hello Dan,

           

          Check in your Rules setup if you have differen cleanses for indidual Nets, Classes, Conditional or other categories that has higher priority that Default 6 mil clearance

           

          Regards, Yan

          • 2. Re: Layout spacing error: can't change rule?
            dmeeks

            No, I can’t see any rules that say 10 mils. If I select one of the nets in question, properties, rules, everything for that net says 6 mils. But when I try to route, it wants to keep a 10 mil space around it. There are several nets like that, for some reason. I have already routed the board, so this is something that has changed during the process of finishing up the board. I am really stuck, my only option seems to be to turn off the design rules, but then I’ll have a zillion rules “violations” to investigate (99% of them will be a false violation, where spacing is less than 10 mils.

             

            Dan

            • 3. Re: Layout spacing error: can't change rule?
              David Ricketts

              I agree with Yan (who seems to be having a bad spell). Sometimes looking at the DRC errors in Router will give you more detail, but the cause is buried in your Design Rules. You may think you have looked at everything, but you missed it. I know I've spent what seems like hours tracking down this exact kind of problem. Conditional Rules is usually what trips me up.

               

              Try running a Rules Report. It's a lot easier to search than picking through all of the heirarchies one at a time.

              • 4. Re: Layout spacing error: can't change rule?
                yan_killy

                Dan,

                 

                ASCII out design by selecting everything. Then uncheck Rules and Miscelinious boxes. Import created ASCII into a blank design and set the Rules to clearance you want

                 

                Regrds, Yan

                • 5. Re: Layout spacing error: can't change rule?
                  DenisL

                  Dmeeks;

                   

                  I have experienced this odd behavior as well. The DRC would indicate a value that simply did not exist in my rule sets. I examined the default rules, the class rules, the net rules, the conditional rules and the differential rules and was unable to locate the value that the DRC routine was reporting.

                   

                  Finially I did an ASCII output of just the Design Rules, and there in the ASCII file I found the culprit. It was a value that had been changed in Layout and although the display indicted the updated value, It's like the underlying value had not changed.

                   

                  I made the correction in the ASCII file (Actually, I deleted the rule) and re-imported the rules ASCII after which the DRC routine worked as expected. I believe this is some sort of bug, but it is very elusive and not easily duplicated. I have experienced this anomaly several times.

                   

                  Denis Lefebvre