4 Replies Latest reply on Jun 30, 2011 8:44 AM by Joel_Pointon

    Back-feed detected

    schubert_brian Skilled

      During a simulation VeSys pointed out a Back-feed.  While I do not doubt that their is a back feed I am unsure about the way it is presented in VeSys.

      Their are three wires all connected in series by inline connectors.  The wire in the middle has a back-feed error while the other two wires do not.

      Is this because VeSys does not update the connected wires to indicate a backfeed.  Similar to how a red wire will be blue on the other end of a wire break.

       

      Is this just a bug with my machine or is there a reason why VeSys only shows the one wire as having a back-feed?

       

      Picture2.png

        • 1. Re: Back-feed detected
          Joel_Pointon Master

          Occassionly you can get a situation where VeSys has the wrong current flow direction, i.e. when you drop additional components or wire breaks into a wire or just move wire ends around.  To resolve the problem you can right click on the wire and select Reverse Direction or you can go to the Design Tools > Design Options > Electrical tab and reset all current directions (VeSys will then relearn them all when you operate switches, etc.)

           

          The problem you see about only 1 wire on a Wire Break being colored is likely due to one of them being a real wire and the other being a virtual wire (although this is hidden from the user as to which is which unless you break the link between the Wire Breaks).

          1 of 1 people found this helpful
          • 2. Re: Back-feed detected
            schubert_brian Skilled

            Ok now I figured it out. 

            VeSys calculates backfeed based on voltage drop and not current. 

            Therefore, the reason only the wire in the middle detects a backfeed, even though all the wires have current going in the wrong direction, is that the wire in the middle is much longer and has a much higher resistance resulting in a higher voltage drop. 

             

            Does VeSys 2.0 calculate backfeed the same way that classic does?

            • 3. Re: Back-feed detected
              Joel_Pointon Master

              VeSys Classic learns the current flow direction when the simulation is in operation, I'm not sure exactly how it does this but it may not use either the current or voltage drop results that are reported back to the user.

               

              I have tested the scenario you described and my system correctly reports every wire that has a back feed.  You could try right clicking on the wire and selecting "Reverse Direction" to see if this affects the results (this feature is usually used if VeSys has "learnt" the wrong direction or you have done mods to the drawing that affect the current direction/connectivity).  Because some wires have bi-directional current flow you can individually disable backfeed detection on wires, so it might be worth checking whether your wires have this option selected.  To enable/disable back feed for individual wires you edit the Wire and then go to the "Display Properties" tab, you will see the option "Disable Backfeed Detection for this Wire" either check or uncheck this option.

               

              Its been a while since I did any simulation in VeSys 2.0 but I believe you have to manually define the current flow direction for each wire, it might be worth checking the latest version to see if it has the VeSys Classic "Learn Mode" functionality.

              • 4. Re: Back-feed detected
                Joel_Pointon Master

                If you are still having problems and would like me to take a look post an example drawing on this forum.