1 Reply Latest reply on Oct 12, 2012 3:26 PM by guy_wettstein

    Licensing ModelSim DE 10.1 on 32-bit Linux Host

    andrew.l.ashworth

      Hello,

       

      I've installed an evaluation copy of ModelSim DE on a 32-bit Scientific Linux 6.3 (RHEL clone) host. The distributor has given me a link to what I believe is a mobile compute license tied to the eth0 MAC address. I've set MGLS_HOME to my mgls dir and MGLS_LICENSE_FILE to the authorization code I received over e-mail.

       

      I receive the following output runing ./mgls_admin -v

       

      mgls_admin: Neither of the environment variables MGC_HOME or MGLS_HOME

      mgls_admin: are set to valid values.

      mgls_admin: Can't get pathname of packaging information file.

       

      mgls_admin: v9.4_4.1 Tue May 10 06:01:04 PDT 2011

       

      Similarly, when I run ./vsim, it complaisn about not being able to find a valid license despite me having set MGLS_LICENSE_FILE.

       

      It seems most of the docs here are for Windows. Are there any instructions for linux? Part of the reason I'm evaluating ModelSim DE is for the Linux support, so switching over to a Windows workstation is an option, but would really impact my workflow. The instructions I read in the modelsim user's manual assume a floating license model with a Flex server/client, but I don't have the right type of license for that, I assume.

        • 1. Re: Licensing ModelSim DE 10.1 on 32-bit Linux Host
          guy_wettstein

          Andrew,

           

          The problem here may well be that you're running on an unsupported Linux platform. We don't test Scientific Linux so I have no idea if our licensing or application software will run on it. There's little I can do to help if it doesn't work.

           

          Nevertheless, if your MGLS_HOME is set to .../modeltech/linux/mgls, it should be working. The messages mgls_admin is displaying are exactly what you get when MGLS_HOME is not set properly. Fortunately, you don't need to set MGLS_HOME to run Modelsim since Modelsim sets it internally. You should double-check the MGLS_HOME or try running Modelsim without it.

           

          Best Regards,

           

          Guy