3 Replies Latest reply on Jan 15, 2009 12:13 AM by bbpcbdesign

    Interactive Plow: little problems in EE2007.3 ?

    bbpcbdesign

       

      Hi all,

       

       

      it seams to me that starting with EE2007.3 some little problems comes up usign interactive plow.

       

       

      I was not able yet to discover how to reproduce them but:

       

       

      1 - Sometimes I'm not able to delete a semifixed trace. I must select other traces and then reselect the original one and delete it.

       

       

      2 - Sometimes I'm unable to start plow from a pad. No chance. As before, I must select other pads and then retray.

       

       

      Never had these problems with previous version.

       

       

      Bortolo

       

       

        • 1. Re: Interactive Plow: little problems in EE2007.3 ?
          mprakash

           

          Hi ,

           

           

                   We are also facing lot of problems in EE2007.3.

           

           

                   Most of the times I'm unable to start the Differntial pair routing . If i route the DIFF pair it s not like a DIFF pair ( We dont know how to route!!!!!!!!!!!)

           

           

           

           

           

          Regards,

           

           

          Prakash

           

           

          • 2. Re: Interactive Plow: little problems in EE2007.3 ?
            Jerry_Suiter

            Hello,

             

            I have reviewed both of these complaints with Interactive Routing in 2007.3 and we cannot reproduce these issues and also have no customer or internal logs describing these problems.

             

            The next time this happens please look at the following:

             

            When the semi-fixed trace is selected and cannot be deleted:

            Does the trace graphically appear selected based on the selection color?

            What does the message fields state when the trace is selected?

            Do you get a message in the message field or output window when delete does nothing?

             

            When you try to plow from a pad and it will not start interactive routing:

            What specifically do you see graphic's wise when you click on the pad within Interactive Plow and it fails to start routing?

            Does the message field or output window give you indication when you select a pad?

            Is this a DiffPair net?

            Does is occur starting on any special pad type like SMD or Through?

             

            When you cannot route DiffPairs as a pair, typically this happens because the software does not see the nets paired. I have seen this in a few different scenarios:

            One of the nets does not have all of it's pins placed. If the software cannot determine a from-to, then it will not route them as a pair.

            The pins are placed two far apart from each other to be seen as a pair.

            Using CES and electrical DiffPairs, the physical nets are not paired correctly. Sometimes you have to simply pair the physical nets in CES instead of the electrical nets.

            In all of these cases, you can simply open Design Status and confirm that the nets are showing up as a DiffPair. If they are, and you still have the problem I would be very interested in the testcase being provided and logged so we can investigate this issue.

             

            In any of these cases, for issues that are difficult to reproduce, we do have the ability to capture these types of problems with Record/Playback when they occur that allows us to investigate and potentially fix these types of issues. Again, I am very interested in fixing any of these issues that we can reproduce with Interactive Routing. Please help me, help you by working with CSD to reproduce these issues.

             

            Regards,

             

            Jerry Suiter

            ExpeditionPCB/XtremePCB Product Marketing Manager

            • 3. Re: Interactive Plow: little problems in EE2007.3 ?
              bbpcbdesign

               

              Hi Jerry,

               

               

              I got it. I found the bug. The problem is new "Editor Control" implementation released with EE2007.3

               

               

              Before to describe the issue I should say that I'm working with dual monitor and in many if not all my pcb, I use "Allow vias under pad" option, so "Pad Entry" form is often open and placed to second monitor as Editor Control window.

               

               

              Here are steps to reproduce the problem

               

               

              AVUP = "Allow Via Under Pad" option.

              PED = "Pad Entry Dialog" form

               

               

              Open a pcb and create a situation like this one described below.

              Square pad with AVUP enabled

              Rectangle pad with AVUP enabled

              Rectangle pad without AVUP enabled

              Oblong pad with without AVUP enabled.

               

               

              -


               

               

               

              What happens is:

               

              1. Open Pad Entry Dialog form

              2. PED get focused

              3. Blank click to focus to Expedition.

               

              Case 1

               

               

              1. Click on a pad without AVUP. PED not focused and pad is highlighted in PED and in Expedition. Expedition focused

              2. As long as I click on pads ( doesn't matter what shape ) without AVUP, PED not focused and pad is highlighted in PED and in Expedition. Expedition focused

              3. If I click on pads with AVUP enabled but with shape equal to previous pad, PED not focused and pad is highlighted in PED and in Expedition. Expedition focused

              4. If I click on pads with AVUP enabled but with shape different from previous pad, PED get focused and pad is highlighted in PED and in Expedition <-- BUG

               

               

              So the problems comes up when you select a pad with a shape different from previous one and with AVUP enabled probably because PED when change from a list of type pads to another type list gets automatically focus to itself.

               

               

              Case 2

               

              1. Click on a pad with AVUP enabled. PED get focused and pad is highlighted in PED and in Expedition <-- BUG

              2. As long as I click on pads with or without AVUP but shape equal to one at step 1, PED not focused and pad is highlighted in PED and in Expedition. Expedition focused

              3. If I click on pads without AVUP enabled and shape different from previous one, PED not focused and pad is highlighted in PED and in Expedition. Expedition focused

              4. If I click on pads with AVUP enabled but with shape different from previous pad, PED get focused and pad is highlighted in PED and in Expedition <-- BUG

               

              So in Case 2 we have the same bug as Case 1 plus another one when click for first time to a pad with AVUP enabled.

               

               

              I think that PED must get focused only when you open it, because this is a user choice.

              After that PED must not be focused. NEVER.

              While user works in Expedition, PED most only update pad type list and highlight selected pad in it's list.

               

               

              I open an SR 2205935115 with DR 00552379

               

               

              At the same time I found another bug related to new Editor Control

              See "F12 Function key doesn't work as expected when Editor Control form is open" SR 2205934944 with DR 00551761

               

               

              I spent some time to find, reproduce and describe the problem. I hope that these bugs will not be classified as...

              "Single customer request. Closed" as sometimes happens.

               

               

              Regards

               

               

              Bortolo Bolis