AnsweredAssumed Answered

Import PartQuest Parts (from dropbox folder) stops working

Question asked by c.goodwin on Dec 7, 2015
Latest reply on Mar 14, 2016 by c.goodwin

I've been using PartQuest successfully for several months.  After a multi-week hiatus from PCB design, I'm working on a new board and went through my typical pattern of selecting a part in PartQuest, setting it to download (into my dropbox, which has been successfully integrated since when I started using PartQuest). 


So far, so good, however: On selecting Tools -> "Import PartQuest Parts" in xDX Designer, I get the message "There is no product license available on your machine. The PartQuest files will not be decrypted." 


The same thing happens if I trigger the import from PADS Layout.


I checked and our PADS licenses are good through 8/2016.


I downloaded and installed the latest PartQuest Integration Utilities, rebooted, same problem.


I deleted the PartQuest folder from the Apps directory of the dropbox and then re-linked the dropbox from my PartQuest profile, triggering the PartQuest folder and all its content to be re-generated.  Still no dice.


I switched to the direct download approach and grabbed the part as a .pqz file, extracted it, then ran the import PartQuest parts menu item to import it, same error, (then I edited the PartQuest.ini file to actually point to the directory with the extracted file and THAT ran properly).  At this point, I would like to go back to the dropbox method rather than manually downloading part by part, but every time I try, it generates the same error.  To check if it had something to do with the files extracted from .pqz files vs files downloaded directly into dropbox, I manually copied a file [that had been pushed by PartQuest to the dropbox directory] into the download folder I'd been extracting .pqz files into, and the import command ran fine importing the file, so it appears the error follows the directory location, not the file delivery method.


Has dropbox functionality been intentionally removed?