7 Replies Latest reply on Nov 14, 2016 10:23 AM by johnduquette

    Change MEG to M in DxDataBook

    nicola.fiorucci

      Hi,

      for my resistor table i would like to display the 10^6 magnitude as M instead of MEG. How can i do this?

        • 1. Re: CHANGE MEG TO M IN DXDATABOOK
          stoane

          Hi,

          i ran into the same problem a few days ago and found a solution. Although it's more of a sloppy one it works!

           

          Close your xDXDesigner and go to "...\MentorGraphics\PADSVX.1.2\SDD_HOME\common\win32\lib" and open the "dxdbdll.dll" with an editor. (better make a backup)

           

          Find line 6794, column 150 and replace "MEG" with "M NUL NUL" and optional "K" with "k". In line 6794 column 234 replace "Mega (MEG)" with "Mega (M) NUL NUL" and "Kilo (K)" with "Kilo (k)".

           

          You need to type those NUL down by yourself, by hitting ALT and typing 256 on the numpad. Don't leave any spaces! I just used them here to make it more readable.

           

               FIND:

               line 6794, column 150:

          OLDDLL.PNG

               line 6794, column 234:

          OLDDLL2.PNG

               CHANGE TO:

               line 6794, column 150:

          NEWDLL.PNG

               line 6794, column 234:

          NEWDLL2.PNG

           

          I hope this helps! You obviously need to do this on every workstation you're using.

           

          EDIT 09/09/2016: This still works with the new VX.2 release. Same file, but different line and column. Just use "Find" in your Editor of choice!

           

          Greetings,

          Fabian

          3 of 3 people found this helpful
          • 2. Re: CHANGE MEG TO M IN DXDATABOOK
            martin.rottmann

            Wow, you should hire at Mentor with your hacking skillz (-;

            We use 'M' for mega, too and as far as I know it ist just because of this setting in the xDx Databook properties:

            "Use European Notation for Property"

            In Databook:

            Ok, the 'k' for kilo is still a capital letter 'K', but we got over it...

            • 3. Re: CHANGE MEG TO M IN DXDATABOOK
              stoane

              No, thanks, I am fine here.  ; )

              BTT:

              I know that setting, but all it does is "using EU notation for property", thus changing 4.7MEGOhm to 4M7Ohm. It's acceptable if you use no units, but with "Ohm" it's as ugly as MEG.

              My solution instead displays the values as 4.7MOhm. Even better with frequencies... 12M56Hz, 12.56MEGHz -> 12.56MHz

              1 of 1 people found this helpful
              • 4. Re: CHANGE MEG TO M IN DXDATABOOK
                martin.rottmann

                Ok, I understand. As we using e.g. "1M5" without "Ohm", I was not aware of this. Thanks for the clarification.

                • 5. Re: CHANGE MEG TO M IN DXDATABOOK
                  nicola.fiorucci

                  Thanks very much Stoane. This solve the problem. This is useful for frequencies values as you mentioned above. We had the same display problem for this field. Thanks again

                  • 6. Re: CHANGE MEG TO M IN DXDATABOOK
                    stoane

                    I just edited my solution to clarify the situation in the new release VX.2.

                    • 7. Re: CHANGE MEG TO M IN DXDATABOOK
                      johnduquette

                      Nice hack!  For reference, the "Meg" is hardcoded and visible the user in the Magnitude column of the Central Library configuration editor (in PADS Library Tools select your .lmc file and <right-click><Edit xDx Databook configuration...>.