0 Replies Latest reply on Jul 5, 2018 2:21 AM by cgreco

    "Get license failed" witth microtec MCCCF compiler on windows 32 bits

    cgreco

      Hello Mentor community,

       

      I have an issue with my old C compiler microtec mcccf (v5.3S) for ColdFire. I use an USB dongle (sentinel) with regular license that perfectly works on windows 7 32 bits. When I install the compiler on Windows 7 or 10 64 bits, the compiler tells me "Get license failed".

       

      The USB dongle drivers are up to date (sentinel v7.80) and the USB dongle is recognised by FlexNet lmtools.

       

      I tried to update "mgls.dll" file with "Mentor_License_Utility" v3.3.5.0 but this file does not exist in microtec compiler version 5.3S. Flexnet documentation for version 5.3S tells that mcccf use DLL "mteclm.dll".

       

      I tried to use version 5.5G and I updated "mgls.dll" file but it still does not work.

       

      I also tried on Windows 10 32 bits and it neither work. Strangly, it does work on a Windows 10 32 bits virtual machine that runs under windows 7 or 10 64 bits.

       

      Did someone succeed in using microtec compiler on Windows 7 or 10 64 bits ?

       

      Thanks very much for you help.

       

      Carlo Greco