12 Replies Latest reply on Oct 19, 2018 3:10 AM by ati-phy

    losing Databook path

    ati-phy

      I have managed to set up the odbc database connection (Access) and configure the "Databook". However, I have to deal with a strange phenomenon whose solution I didn't find.


      Although the path is correctly assigned in the settings, it must be reassigned manually each time the Xpedition designer is started (see pictures). Since I also need to set up the system for students, this bug should be fixed.
      Where is the faux pas?

      Another case that concerns me is the creation of a template (all necessary settings already prefabricated) for the Xpedition Designer. For the layout, I did it easily according to the instructions.
      Which ini files do I have to copy from the preconfigured project into the new one?

      Is there a more elegant method for this?

      Finally, no help documents are included in my installation, even though I did a standard install. How can I add this in retrospect?

       

      Thanks.

        • 1. Re: losing Databook path
          robert_davies

          I don't know why you get the errors is you say it works the first time, you should look in the .dbc file for issues. You could use an environment variable rather than the mapped drive and quote it as ${ENV_VAR} to see if that helps.It may also be an issue with the - in the path names.

          For templates in Designer see this posting Re: Defining border attributes and border.ini file location

          Towards the bottom of my reply I go on to cover template projects.

          For the documentation you need to download them and install them separately.

          • 2. Re: losing Databook path
            ati-phy

            Hi Robert,

             

             

            thank you for your hints.

             

            The Databook was reconfigured and the right path to the database didn't work from the beginning. The experiment with the environment variables didn't work either. If I start Xpedition Designer the system will search after the database in the project path which is not entered in the settings (see first thread).

             

            Once the system set up correctly everyone should have on their own PC the same initial condition with the right path to the Databook, the template for Xpedition Designer and Xpedition Layout. (The template for the layout is localized in Cetral Library (server) which is accessable for everyone.)

             

            In the .dbc file I couldn't find any mistake, since I didn't understand it at all.

             

            Where could be the mistake?

             

             

            Since the template for the Designer is locally saved (your described approach) no one would have access to it. Where should be saved the mentioned files instead?

             

            Finally, where can the documentation files be downloaded?

             

            Thank you in advance.

            • 3. Re: losing Databook path
              robert_davies

              To support multiple users having access to common templates you need to set up an additional common WDIR path - we generally refer to this as a 'Corporate WDIR', it would be on a common shared drive (probably where you keep your library) and the templates would be copied there using the same folder structure as described in the linked post. Your WDIR would then have three paths, 'Your personal WDIR'; 'shared WDIR'; Installation location, the last one is automatically added by the system.

              There is a tech note on this if you have access to SupportCenter  https://support.mentor.com/en/knowledge-base/MG590075

              As to the issue with the database file, the third picture doesn't really help: the .dbc file is the configuration for Databook, it should reference the DSN name you created for the ODBC connection you made in step 1. But you don't say what that was or where the database is located.

              • 4. Re: losing Databook path
                ati-phy

                With your instructions I found out that in the .dbc-file the name of the DSN is "MS Access Database" but inside the system source the name of the DSN is "Prisma-Detlab". I copied the .dbc-file and changed this mistake completely and pasted back but afterwards following error (see picture "Errormessage") occured.

                 

                How can be this remedied?

                 

                 

                Unfortunately we have no access to SupportCenter, since we are a university we don't have a commercial licence. How can I be helped in this case?

                 

                 

                For the Xpedition Designer template would be really helpful to describe it in one example because it doesn't work in my system.

                 

                Thank you very much in advance.

                • 5. Re: losing Databook path
                  robert_davies

                  To create a template simply create a new project, set the pointer to the central library & databook configuration. Next make the pointers to the special components file, the bus contents file and the borders file relative to the project - see the first picture.

                  Now add the special components to the project via the special components dialog and set the sheet borders as appropriate (I have shown a couple of examples but these will be specific to your environment). Once done close the project and browse to the file location where you created this project. Create your shared WDIR as described earlier and copy the .prj file, the speccomp.ini file and the borders.ini file to the shared WDIR in the following folder:  Templates\DxDesigner\Expedition.

                  Now you should see the new template (based on the project file name) in the list of your templates. See also the Xpedition® Designer and Xpedition® System Designer Administrator’s Guide in the documentation set.

                  When you create a new project using this template the borders.ini and speccomp.ini will be copied to the new project location. The busconts.ini will be created there but empty until you add bus contents (if you use them).

                  Template1.PNG

                  Template2.PNG

                   

                  Template3.PNG

                   

                  Template4.PNG

                  There are some useful videos here on subjects that typically get raised by users Design Creation

                  • 6. Re: losing Databook path
                    robert_davies

                    How did you create the dbc file in the first place? You can edit it from Designer by opening Databook and from there use the context menu on the RMB - Configure - Edit Configuration. Then you should be able to reset the dbc file to the correct settings.

                    • 7. Re: losing Databook path
                      ati-phy

                      Now, I succeed to setup the correct Databook configuration, to set the local enviromental variables and the self-created Xpedition Designer templates. All  works fine (locally). Thank you for that.

                       

                      Since I have no access to the Support Center (https://support.mentor.com/en/knowledge-base/MG590075) I couldn't create a 'Corporate WDIR' to share the templates with the students' computer. I couldn't download the help documents to install them, too.

                       

                      Additionally I got one more issue with the Xpedition Designer. It shows the pin numbers of the symbols twice (see picture). How can be this turned off?

                       

                      Thank you.

                      • 8. Re: losing Databook path
                        robert_davies

                        Setting a third 'CorpWDIR' is really very simple, let's assume you have a shared drive mapped to M: On this shared drive create a folder called SharedWDIR so you have M:\SharedWDIR.  Also assume for illustration that you personal WDIR is C:\UserWDIR, then in your WDIR environment variable you set WDIR=C:\UserWDIR;M:\SharedWDIR. Put your templates in the SharedWDIR and they will be picked up from there and all students will have access to them.

                        To check for the double pin numbers look in your symbols it might be you have Pin Number in there twice or you might have Pin Number and # which is the 'netlist' equivalent property, make sure your symbol only has one Pin Number property per pin, also check that your pin Name, if it is the same as the pin Number is not being displayed on the symbol (the value seen inside the symbol body). Usually pin 'Name' is given the function of the pin such as Clock and this is displayed in the symbol graphic and Pin Number is used for the physical pin on the PCB. So you have pin Name=Clock, Pin Number=1. It looks like you might have pin Name=1, Pin Number=1.

                        • 9. Re: losing Databook path
                          ati-phy

                          The original templates for Xpedition Designer are in my case not in the WDIR. They are deeply hid in the installation path.

                          I did this here (see picture: enviromental variable.jpg) and of course this doesn't work? Where is/are my mistake/s?

                           

                          For the twice pin numbers I made two screenshots to show that these are not the names and pin numbers. If you just have a look on the resistors in der picture xp-deigner.jpg there are really the pin numbers visualised twice. One smaller and the other bigger size.

                           

                          There are no twice pin numbers in the editor visible.

                           

                          Thankl you.

                          • 10. Re: losing Databook path
                            robert_davies

                            The shared WDIR path has to be the WDIR path for the release, depending on which release you have it will be WDIR_EEVX_n_m and you make this path include both locations:

                            For VX.2.1 for example WDIR_EEVX_2_1 is the variable and its value would be the two paths:

                             

                            WDIR_EEVX_2_1=C:\UserWDIR;M:\SharedWDIR

                            The templates need to be put into the same folder structure in the WDIR as the installation path so your shared folder would look like this:

                             

                            M:\SharedWDIR\Templates\DxDesigner\Expedition and the project file and others would be stored there.

                            The reason you see two pin numbers is because you have named the pins 1 to 7 and C1 C2. You will note C1 and C2 only have one pin number each, 1 and 2 (the actual Pin Number property) and pin Name C1 and C2. Pins 1 to 7 have Pin Numbers 1 to 7 and Names 1 to 7.

                            • 11. Re: losing Databook path
                              ati-phy

                              First of all many thanks Robert for your patience and help.

                               

                              Unfortunately the template for Xpedition Designer on the students' PC still doesn't work.

                              I have created the following environment variables: (see appendix: enviromental variable.jpg)

                              I think it's the drive letter "W". This is not the same like on other PC. How could this be bypassed?

                              The structure of the folders is arranged as you described it.

                               

                              The issue with displaying the pin number twice could not be solved either. Here is a screenshot of a connector with different pin names and numbers and still the same problem occures. Isn't there a check mark somewhere in the settings with which the display can be filtered?

                               

                               

                              The question how to provide the documentation for the help files to install it a posteriori is still open.

                              • 12. Re: losing Databook path
                                robert_davies

                                The issue with the templates is probably to do with the root of the shared directory, I have created the same folder structure on my machine:

                                D:\EDA\PXDL-PCBLIB\SharedWDIR and shared this, the share becomes: \\machine-name\EDA and I have mounted this on W. The shared path is therefore W:\PXDL-PCBLIB\SharedWDIR and the WDIR is as follows:

                                WDIR_EE_VX_2_1 = C:\WDIR;W:\PXDL-PCBLIB\SharedWDIR

                                The path to the templates is: W:\PXDL-PCBLIB\SharedWDIR\Templates\DxDesigner\Expedition

                                The  content of this path is as shown:

                                Content.PNG

                                 

                                When I create a new project the A1_Shared template shows up in my list of available templates:

                                 

                                Newproj.PNG

                                 

                                So check the root of the share and check the environment variable is correct, you may do this by opening an MGC command window and running the set command to list all of the variables you have set up, it may be that the variable for your real WDIR path is not  correct.

                                 

                                For the connector please send me the symbol file to robert_davies@mentor.com.

                                 

                                For documentation go to the download page where you downloaded the software and choose the documentation set, if you had the software delivered on media then request the documentation from whoever supplied the software to you.

                                 

                                 

                                Docs.PNG