AnsweredAssumed Answered

Second @PRINTORDER property added from "Update Other Objects..."

Question asked by tmiddleton on Oct 15, 2018
Latest reply on Oct 20, 2018 by tmiddleton

I'm having odd behavior in a schematic with using @PRINTORDER. Note, that I am still just setting this up to work so maybe there is something broken. Prior, the @SHEET property was being used for our page numbers (eek) so I'm trying to get this working to improve our tool usage flow.

 

On to the issue.

 

So far I have used the the @PRINTORDER property I added to a border on a couple projects and it has worked.

Now, what is happening is that I am using it on a new project and the sheets are not updating correctly.

For example:

Where the ? is the @PRINTORDER field and I end up with two properties on the border:

Interestingly is that they are the same, but not entirely when you look at the bottom of the table:

This is the above properties respectively. Note the top property is the added one (determined by the visibility of the Property Name)

 

 

What is more puzzling, is that if I add the @PRINTORDER property to the sheet before doing the update, it updates both of the fields. However, if I delete the added one, it goes back to '?'

 

Also, sheets in the schematic, which were copied in from a schematic with the update PRINTORDER working updated ok in the same schematic and had the right sheet numbers after doing a "Reset Sheet Order".

 

 

 

The symbol is the same as on other schematics, and I have tried:

1) In this project, deleting and re-adding the border symbol

2) Doing the "Reset Sheet Order" (which helped only with sheets I copied in)

3) Doing a "replace" (vs. delete border, insert border)

4) Doing the delete/add on a different, previously working schematic which is pointing to the same schematic symbol. (This worked fine and did not cause the ? to appear)

 

 

To summarize, new sheets in this schematic seem to not update properly. Sheets I copied from a different schematic where this was working seem to continue to work. As far as I can tell the sheets are created from the same symbol.

 

 

I have looked through various settings and not seen anything that jumps out, I've also done a textual compare between the two project work areas of files, settings, etc and haven't been able to locate a meaningful difference.

 

Thanks!

Tom

Outcomes