AnsweredAssumed Answered

Mystery parts in a PADS Logic shematic

Question asked by smercurio on Jun 14, 2010
Latest reply on Jun 17, 2010 by smercurio

While investigating something else I was looking at an ASCII export of a PADS Logic Schematic. We are running PADS 2007.4, but I see the same thing happen in 9.0.2. In the ASCII exported file, there are parts listed on one sheet that I cannot find anywhere on the schematic. For example, here is one part, as listed in the ASCII file:

 

RX1          $$RX1            11850 12000   0 1 100 10 100 10 2 5 5 1 0 0
"Default Font"
"Default Font"
830 700 0 0 100 10 0 "Default Font"
REF-DES
780 -190 0 2 100 10 0 "Default Font"
PART-TYPE
0 0 0 0 0
1 0 0 0 0
2 0 0 0 0
3 0 0 0 0
4 0 0 0 0

 

This supposedly defines a part that has a part type of $$RX1. I have a few issues with this:

  • I cannot find the part in the list of parts in the tree in PADS Logic.
  • I cannot find the part if I search for it.
  • I cannot find part type $$RX1 anywhere in any of our libraries, or on the schematic. The part type shows up in the ASCII file, but does not show up in the tree that lists all the part types in the schematic.
  • The ASCII file also has an $$RX1 CAE decal, but I also cannot find that decal anywhere from within PADS Logic.
  • The header claims that there are 5 attributes, but you can clearly see there are no attributes listed.
  • If I go to the coordinates specific in the header there is no part there. The coordinates are in the middle of a wire.
  • If I run the "Update From Library" tool in PADS 9.0.2 then I get several error related to these phantom parts, part types, and decals. For the $$RX1 decal, for example, it gives me an "
    Cannot get CAE DECAL from Library !!!" error.
  • If I import the ASCII file into PADS, and then re-export, these phantom parts, part types, and decals still show up. I've tried this with PADS 2007.4 and 9.0.2.

 

Can anyone offer suggestions as to what might be going on?

Outcomes