1 2 First Previous 19 Replies Latest reply on Oct 14, 2010 3:48 AM by MaBUa

    USB dongle can't be detected

    MaBUa

      Hello all,

      has somebody bumb into the same problem as me?

      I have a new desktop PC and I do whatever the USB dongle is not seen by Mentor Graphics tools.

       

      The last driver HASP aladdin is installed, I have a valid license, path to lic. file is correct....

       

      It seems to be affected by  the new hardware....?? - my opinion... se the picture of my HW configuration.

       

      Does mentor guys met this problem too?

       

       

      Many thanks for help

      Martin

        • 1. Re: USB dongle can't be detected
          strangd

          Go to your Windows Start menu and under Mentor Graphics Licensing select LMtools.

           

          Select the tab - Systems Settings.  In the box to the right of FLEXID you should find the dongle codes for all of the dongles plugged into your USB ports.  If you have a parallel port dongle nothing is going to work, the HASP drivers connect to USB devices.

           

          Since your are running LMtools you probably loaded the Mentor License Server software from the Installation program and told it to load the HASP dongle license interface. If there is no dongle ID number in the FLEXID box that matches the FLEX ID number in your Mentor licence file, then the Mentor software will not work.  Go to XP System Properties and under the Hardware tab select the Device Manager button.  Slide down to the Universal Serial Bus controllers and look to see if the Aladdin HASP Key is listed.  Double click the HASP Key entry and see if Windows thinks that the hardware key is working and Enabled.  Run troubleshoot if needed.

           

          If you do find you hardware key is listed in the FLEXID box, then under LMtools select the Sever Status tab and Perform Status Enquiry. You should see a listing of FlexLM licenses that are available to run.  Go to the Sever Diags tab and run Perform Diagnostics.  Chase down any error that the software finds.

           

          Under the LMtools Start/Stop/Reread tab you can start the FlexLM service, Stop the FlexLM server and Reread the license file.

           

          If there is still nothing working, then open Windows XP Services and see if the HASP License Manager is started.  In Windows Task Manager you should be able to see lmgrd.exe is running and if it is not then the FlexLM service is not running.  Reload the FlexLM license server software from the Mentor Installation disk.

           

          I am running an older HASP and FlexLM service than EE7.9 and the Mentor software still runs.  If you are also using a FlexLM floating license server, then you should update the floating FlexLM license server to the version delivered with EE7.9.

           

          Good luck

          Dwain

          • 2. Re: USB dongle can't be detected
            Joel_Pointon

            Hi Martin,

             

            When I have had licensing/dongle problems with new machines I usually follow the process below, a lot of the suggestions are the same as 'strangd' has suggested so I haven't gone into detail for each step (between these 2 posts you should be able to get it back up and running).

             

            1. Is the LED on the dongle illuminated?  This is an easy initial check to see if the dongle is installed properly (If the LED is off then LMTools won't help you).
            2. Check to make sure that the PC can see the FlexID of the dongle.  To do this run LMTools and go to the 'System Settings' tab look at the FlexID section, if your dongle isn't displayed then you may have a faulty dongle or the drivers are quite working - maybe try re-installing the drivers or strangely try inserting the dongle into a different USB port (it does sometimes make a difference to USB devices).
            3. Check that the license file you have refers to the FlexID of the dongle that you are using.
            • 3. Re: USB dongle can't be detected
              MaBUa

              Good morning Dwain,

              here is the summary I'e checked:

              - in Lmtool I SEE the FLEXID

              - FLEXID fit to FLEXID in my license file

              - the USB dongel is pluged and lighting

              - aladdin HASP key is in the list - device is working properly

              - Now I sucessfuly reread the license file - last week It was not able (it failed)

              - Now the Key check (in MG license utility) sucessfuly detect my USB key - last week doesn't detected.... strange

               

              Hope, it will work forever

               

              Thank both of you, guys

               

              BR

              MaBUa

              • 4. Re: USB dongle can't be detected
                MaBUa

                Hi Guys,

                I logout yesterday at the end of my working hours and login today in the morning.... what do you think about the USB dongel?

                I doesn't work again

                 

                - I cant see ID of my USB dongle in LMtool in the FLEXID window

                - tryied to unplugg the dongle and reinstall the drivers - preblem remains

                - tryied to restart the system - doesn't helped

                - in Device Manager there is detected the plugged USB dongle successfuly

                 

                Where is the problem???

                ( hammer is the solution? )

                t was coincidence that it worked yesterday?

                 

                really don't know what to do...

                 

                thanks for your guesses

                MaBUa

                • 5. Re: USB dongle can't be detected
                  Joel_Pointon

                  Did you try a different USB port?

                  • 6. Re: USB dongle can't be detected
                    strangd

                    At the top of the problem list is mechanical connection problem between the USB hardware key and the USB port.  Try another USB port.

                     

                    After the hardware key is plugged in another USB port, if the message window pops up and says New Hardware Found, then the USB key, itself, as the problem moves down the list.  When I built my last workstation I mounted USB ports on the front of the enclosure so that it would be easier un-plug the key and go.  But the motherboard header for that USB cable connect proved to be unreliable even though the pins are gold plated.  My key now plugs into a USB cable that in turn plugs into one of the motherboard mounted USB connectors on the back of the machine.

                     

                    Go to the Windows Start menu and under Accessories | System Tools select System Information.  Under Hardware Resources open Conflicts/Sharing then look to see if anything is said about the USB port being in conflict with another resource.  Under the Software Environment | Windows Error Reporting check to see if there are any errors listed for the USB key port or HASP driver.  Also under Software Environment is System Drivers, check to see if the HASP programs are loaded.  There should be four (4) all start with aks*.  aksfridge should be set to Auto under the Start Mode column.  Under Components | USB there should be five (5) Aladdin * key listings under Device.

                     

                    Good luck

                    Dwain

                    • 7. Re: USB dongle can't be detected
                      MaBUa

                      Hi Guys,

                      thanks for your messages.

                       

                      It still doesn't work... I made a some snaps for you to see what system says.

                      - the red light is illuminate on the dongle

                      - USB dongle work on my old PC

                      - the USB drivers I reinstalled several times

                      - tryied to check out some feature from my license file - feature is seeing but can't be checked out because the invalid host

                      - I have plugged USB dongle on the back side of my PC

                       

                      now some snaps.. are after reinstalling the drivers and tryied to plug into 2 of USB ports.

                       

                      I haven't had a problems with dongle on old machines I had... it is apparently by the new HW system... in my oppinion.

                       

                      Bye Martin

                      • 8. Re: USB dongle can't be detected
                        MaBUa

                        and here is rest of pictures...

                        • 9. Re: USB dongle can't be detected
                          Joel_Pointon

                          Your new machine isn't 64bit is it?  I know there were problems with the dongle drivers and 64bit machines but this was a long time ago (1-2yrs).

                          • 10. Re: USB dongle can't be detected
                            MaBUa

                            My OS is WinXP 32 bits

                            processor is 64 bits (i5)

                             

                            MaBUa

                            • 11. Re: USB dongle can't be detected
                              strangd

                              Hi Martin:

                               

                              My Mentor USB hardware key is listed as an "Aladdin HASP HL key" in the Device Manager window. I also have an older OrCAD USB key that displays "Aladdin HASP key."  With the Device Manager window open and the Universal Serial Bus controllers expanded, you see the key as pictured. Pull the USB key out of the port and the Device Manager window will refresh itself and remove the Aladdin listing.  Plug the USB key back into the USB port and Device Manager will add the Aladdin HASP key back into the list.

                               

                              So your key is working but FlexLM is not seeing the hardware key ID number.  It would be interesting to see if the Aladdin HASP HL key driver is any different than the Aladdin HASP key driver.  In  the Device Manager window double click on the Aladdin HASP key.  Make sure that the key is enabled.  Select the Driver Details button to open the Driver File Details window.  I have four (4) files listed: akshhl26.dll, aksllmtp.exe, aksfridge.sys and akshhl.sys.  Again, I have a Mentor USB key that uses the HASP HL series.  Close this window and go back to the Properties window.  Update the USB drivers.  Try the WEB search first before going back to the install disk.  You might want to try the Uninstall button and then loading drivers.

                               

                              For the Aladdin HASP key listing I have three (3) files: akshsp50.dll, akshasp.sys and hardlock.sys.

                               

                              Run through the same sequence with the Aladdin USB Key listing.

                               

                              Dwain

                              • 12. Re: USB dongle can't be detected
                                MaBUa

                                Hi Dwain,

                                I have 2 pcs of USB mentor hw key.

                                 

                                I have mentor distributed Aladdin HASP driver... 3 files (akscoinst.dll, akshasp.sys, hardlock.sys)

                                This device is enabled.

                                I used the mentor license utility v1.4.3 plus I tried to download the latest drivers from web - it is the same.

                                 

                                As you told... the Flexlm doesn't see the HW on my machine

                                 

                                BR

                                Martin

                                • 13. Re: USB dongle can't be detected
                                  strangd

                                  Well, now we know that you are not loading the same library dll as I am.  Since both my OrCAD Aladdin HASP key and my Mentor Aladdin HASP HL key are using the same drivers and the akshsp50.dll is loaded on my machines, not the akscoinst.dll on your machines, that dll looks to be a good place to start. Unload the Aladdin HASP key drivers.  Don't update over top of them.  Pull the key from the USB port, wait a minute and then insert the key into a USB port.  Windows will find new hardware.  Load the Aladdin HASP HL key drivers.

                                   

                                  The HL drivers should be on the Mentor distribution disk but you can download new drivers from manufacturer on the WEB. (Which is what I would do.)  Don't let the install routine automatically select the new driver.  Use Have Disk selection and browse to the HL driver directory.

                                   

                                  It is possible the Windows will not agree to load the HL drivers to a non-HL key.  You could to find someone who has an HL key, use the HL key to load the drivers and then pull that key out and replace it with your key.

                                   

                                  Or it may be time to let Mentor fix it for you.

                                   

                                  Have fun

                                  Dwain

                                  • 14. Re: USB dongle can't be detected
                                    MaBUa

                                    Hi Dwain,

                                    thanks for your notes...

                                     

                                    I made my best but it doesn't work

                                     

                                    I describe what I made:

                                    - uninstall my USB driver

                                    - downloaded the driver from aladdin web page (see picture "hasp_DRIVER_DOWNLOAD.JPG" )

                                    - installed, unpluged the key and restarted

                                    - login, pluged the key (the driver was loaded)

                                    - look into device manager (see the picture "a_new_HASP_driver.jpg")

                                    - look into system infor for drivers (see the picture "A_new_HASP_driver_1.jpg")

                                    It worked

                                     

                                    After I loggout myself and login back the problems occured:

                                    - look into the device manager (see the picture "a_new_HASP_driver_after_logout.jpg")

                                    - looked into the sysinfo (see the picture "a_new_HASP_driver_after_logout_sysinfo.jpg")

                                    apparently this doesn't start - I don't know what to do to set it to start AUTOMATICALLY...?


                                    Doesn't worked

                                    - unpluged the key and restarted (see the picture after restart my machine "a_new_HASP_driver_after_restart.jpg")

                                    - after next restart the status doesn't changed

                                     

                                    I don't know what to do with it....???

                                     

                                    Thanks

                                    Martin

                                    1 2 First Previous