1 Reply Latest reply on Jul 29, 2011 11:52 AM by m.soucek

    putboard in fablinkXE causing fablink to crash

    m.soucek

      Hello all,

       

      I have problems with putboard method in FablinkXE ( 7.9 ).

      I tried using placeboards.vbs distributed with expedition, I also try to minimise this script to almost simple placeboard call.

      After seeing the progress bar of board loading, both result in "The application has encountered unrecoverable error ... Do you want to attempt to save the design ?"

      It does not matter if any board is already on panel or not, if drc is on or off ...

      If you let the design save before restarting the app, the board is there !

      So the error comes after board placement.

       

      So I tried to call this from C#.

      It ends with COM server error - as expected. But the fablink did not crash completelly.

      If I surround it with try / catch, and ignore the exception, it looks working.

      But - when you close the fablink, and take a look at running processes, you will find several FablinkXE zombies.

      So this is also not a solution ...

       

      Once I found that when I call it with opened the "Place board" window in FablinkXE ( as if you want to place the board manually ) it looks also working without resulting into COM error.

      So I tried to surround call of placeboard with opening and closing this dialog.

      It is slow, and it also creates zombies ...

       

      But there must be a way how to make it working, minimally the placeboards script should work.

       

      Anybody has an experience with this ?

       

      Please help.

       

      Milos Soucek

        • 1. Re: putboard in fablinkXE causing fablink to crash
          m.soucek

          We just moved to 7.9.2 in company.

          With this, I am still not able to make placeboards script working.

          But - it looks like C# access with ignoring generated exception is not creating zombie fablinkxe processes anymore.

          So it looks like good step forward.

           

          I am still thinking about why the vbs is not working ... ( and C# also - with ignoring the exception it places board, but I did not get the new board object as return of the placeboard method )