2 Replies Latest reply on Apr 10, 2012 2:25 PM by ben_painter

    Hello.. need help.

    jaimin_247

      Hey there.. i'm jaimin.

       

      i have problem with modelsim pe student edition 10.1a license key.

      i had installed it few weeks ago. and when i try to simulate it shows error.

       

       

      # //  ModelSim PE Student Edition 10.1a Feb 22 2012

      # //

      # //  Copyright 1991-2012 Mentor Graphics Corporation

      # //  All Rights Reserved.

      # //

      # //  THIS WORK CONTAINS TRADE SECRET AND PROPRIETARY INFORMATION

      # //  WHICH IS THE PROPERTY OF MENTOR GRAPHICS CORPORATION OR ITS

      # //  LICENSORS AND IS SUBJECT TO LICENSE TERMS.

      # //

      # // NOT FOR CORPORATE OR PRODUCTION USE.

      # // THE ModelSim PE Student Edition IS NOT A SUPPORTED PRODUCT.

      # // FOR HIGHER EDUCATION PURPOSES ONLY

      # //

      # vsim -gui work.and_tb work.anda

      # ** Error: ModelSim PE Student Edition license key file not found at C:\Modeltech_pe_edu_10.1a\win32pe_edu\..\student_license.dat.

      # ** FATAL ERROR: ModelSim PE Student Edition licensing failure due to one or more problems with the license key such as:

      # - it is not found

      # - it has expired

      # - it is not for this user

      # - it is not for this computer

      # - it is not for this version of ModelSim PE Student Edition.

      #

      # Please go to http://www.model.com and download an updated copy of the ModelSim PE Student Edition.

      # Error loading design<<<

       

      that's the Error.

      i had uninstalled it and reinstalled it.. and also saved license key at which is sent by mentor graphics. but still same problem.

      i'm sending some snapshots u can see it.

      and also env veriables settings..  and when i click twise on test file modelsim invokes multiple times.. i dont know why this happens.

      please reply me if you have any idea..  jaimin_247@yahoo.co.in    

        • 1. Re: Hello.. need help.
          ken_foster

          Hello Jaimin,

           

          There was a similar thread recently that might be of interest to you:

           

          http://communities.mentor.com/thread/8815?tstart=0

           

          I see you are on an Apple computer and are probably running Parallels or some other Windows emulator. Note that the other gentleman that was having an issue with ModelSim PE found an issue with the Safari web browser. The information is in the thread.

           

          Mentor Graphics provides the student edition of ModelSim PE free of charge, but it does not include any support. You can use this forum to solicit help from your peers. There is also a Google group that has a lot of information.

           

           

          http://groups.google.com/group/modelsim-pe-student-edition?pli=1

           

          Best Regards,

           

          Ken Foster

          Mentor Graphics Customer Support

          • 2. Re: Hello.. need help.
            ben_painter

            Hi Jaimin,

             

            Make sure that the license file you received is found in the location specified by the environment variable MGLS_LICENSE_FILE:

             

            set MGLS_LICENSE_FILE="C:\Modeltech_pe_edu_10.1.a\student_license.dat"

             

            You can analyze the licensing debug output by setting

             

            set MGLS_DEBUG_LOG_DIR="C:\Modeltech_pe_edu_10.1.a\"

             

            and take a look at the "debug_log_######.txt" file that is produced after running Modelsim.

             

            The debug log should show which license file was used and the reason the license request was rejected.

             

            Hope this helps,

             

            Ben